reply as

My comcast email forwards to my icloud account, which is added to em mail. I am trying to phase out my comcast account and reply to emails using the icloud address. However when I reply to a message that comes from my comcast email the default From: address is comcast instead of icloud. I can switch it manually each time but I was hoping for a setting that says “Reply to all emails using me@icloud.com

Hi, do you have your comcast account setup as an alias? If you have the account as alias eM Client automatically detects that the mail was sent to that alias and uses that address as the from address, this is unfortunately a feature of eM Client that can not be disabled, unless you want to keep using the alias.

Thank you,
Paul.