Reply and Forward email content is double spaced but in read only mode, perfectly fine!

Hi there.  I have read all forum details relating to double space replies and have tried everything (removed signature completely - no copy / paste plus ensured that I have latest update installed and have even downloaded the repair file) but nothing is working.
ALL HTML reply and forward email content in body formats to double spaces.  This is NOT the issue in plain text which appears to be working fine.  I do not want plain text . 
What more can I do?  Thank you so very much!

Hi Shell,
the double-space issue was actually happening in Plain text emails and that is the one that we fixed, so I believe you might be experiencing a different problem. Could you take a screenshot of the problem? Does this happen to all emails or just to some recipients/senders? If the double spacing is set in the HTML we might not be able to fix this issue though.
What version do you have currently installed, and what is your Mail Format setting in Tools>Settings>Mail>Compose?