Remove obsolete address suggestion

How do you remove email suggestions that pop up when entering an email address, where the address is no longer in your contacts list – it’s an obsolete one that has been changed. It is too easy to accidently choose the wrong one. I no longer want it to pop up as an address option. “Clear recipients history…” does not work, and I don’t have store and use old selected. I am on the latest version of emclient 9.2.2093
Screenshot 2023-09-10 145742

Have you also tried clicking the X at that end of the addresses when you compose emails to remove them ?

Yes, I click the X to remove the old one from the TO: field. but the next time I create an email to “Mark” both of them are still there. There is no X in the suggesteds drop-down. In the settings>compose>show recipents (history)… there are no entries. I think this issue has been discussed here previously, but I don’t find that thread now.

Also eM Client “checks your Contacts from all accounts selected for suggestions”, when you type, so if you are still seeing suggestions that you don’t want, I suspect they are coming from there.

So search / edit your contacts for those suggested email addresses still appearing and change or delete them. They must be still in there.

You can also normally see which contacts they are coming from by eg: When you compose an email, “click on the icon To” on the left of the field where you type in. This brings up your default selected contacts and if you have more than one account contacts you can select between them in that screen. Just another way to see / edit and delete them apart from going directly to contacts

You were right, the old email address was in a contact that didn’t have the person’s name in it. I deleted that contact, emptied the names history, restart emclient, and when I enter “mark” in the To: of a new email both the old and new address show up in the drop-down. Go figure. )o:

The only other thing I can suggest, is “export all your contacts” via eM Client Exports Contacts option in the menu.

Then delete all your contacts fully out of eM Client contacts from all your accounts.

Next manually open your exported contacts and look / search through them for any of those suggested email addresses and delete any if found. Eg: You can sometimes find them easier when exported looking in a spreadsheet view.

Then re-import them again into eM Client and see if they still then appear. Good luck.

This seems like a bug in emclient’s clear contact history function. That I or everybody else would have to do what you suggest doesn’t seem right. I will live with it for now in the hopes that emclient will resolve the issue in an update.

As I say, this is not the first time this issue has been discussed on this forum. It was my understanding that this was to be fixed in an upcoming release. I guess it didn’t get on their list of bugs.

The address exists somewhere otherwise it won’t be suggested. In 9.2 we offer suggestions from (1) your contacts, (2) previously sent messages and (3) the recipient history.

The option in Menu > Settings > Mail > Compose > Email Address Suggestions allows you to disable (2) the sent folder suggestions and (3) the recipients history. If you have done that as in your screenshot above, AND clicked on Save & Close to save the setting, then the suggestion won’t be coming from there. The only other place the address suggestion can come from are (1) your contacts. You will need to search your contacts to find the obsolete address.

You can click on Clear Recipients History to clear it, then click on Show Recipients and you will see it has been cleared.

I found it. Because of various email cleanups and imports it was in a different contacts list. I guess emclient searches ALL of the contact lists, not just the one I have select with a check mark.


Gary - thank you for adding the reminder “AND clicked on Save & Close” to save the setting. That fixed the issue i had.