Question regarding printing multiple emails

New to trying out EmClient… It’s really really good but for our office we have a specific need associated with printing emails… Currently we use an old v78 version of Thunderbird – new versions of Thunderbird have a completely different print subsystem and the functionality we desire in v78 is gone…

So… we are trying EmClient and all is good but the printing is much the same as the new Thunderbird variant.

Say we have 3 emails to print – the first two are short and easily fit on a single page… but the 3rd is long and spans 1.5 pages…

When we select these emails for instance and press Ctrl-P to print. We want each email to be printed separately – like on it’s own sheet(s)… But the first email is short and fits on page #1 and the 2nd email shows up on the backside of the first page which is NOT what we want.

We would want page 1 having email #1 on it, page 2 having email #2 and page 3 (and its backside) showing email #3 if it’s long spanning more than one page.

I hope that makes sense… Currently I don’t know how to get EmClient to do this sort of behavior. We turned on the “Print each mail on a separate page” but it made zero difference.


sábado 16 julio 2022 :: 1050hrs (UTC +01:00)

Hey @ps23Rick

You can check and try this.
After you click print the eMC print screen should open,
at the bottom edge of this screen click on:
Print using system dialog, your default printer screen will open,
from here you will have more control over what and how it prints.
You should be able to select duplex/double sided etc
If these items are not visible select properties/preferences
to locate choices you have.
The wording might vary dependant upon your printer and my
translation from Spanish

¡Buena suerte!

¡Saludos desde Valencia la soleada en España!


[email protected]

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

Yes, @skybat’s instructions will help you with the duplex printing.

For printing each message on a separate page, just change the setting here:

Hi all… I’ve tried both of those settings – initially I used the system print dialog and of course we’ve got duplexing enabled by default on this printer… I did enable the EmClient setting “print each mail on a separate page” but saw no difference in the output.

For us what we are printing are order sheets and if I select multiple order sheets to be printed regardless of whether they span multiple pages, we want the orders to never share the same physical page which is exactly what is happening here.

In a sample I’ve got sitting in front of me, there are 2 orders – one requires a single printed page (front side only) and the 2nd order spans two pages (front & back). But EmClient, when it prints these as a single print job, prints the first page (email #1 - front sheet only) and on the back of that page prints email #2’s first page and the remaining of email #2 overflows onto the 2nd sheet… I hope this makes sense.

Ideally the way I’m hoping & looking for would be to have email #1 print on the front of page #1 and nothing on the back and Email #2 would take up page #2 front and back.


You will need to print them separately.

Thanks Gary… I’m looking into print management software that might be able to get us past this hurdle by acting as a front-end to the actual printer and potentially allow us to continue to looking at EmClient which I otherwise like quite a bit. Thanks!

If you choose to print multiple messages on separate pages, it doesn’t mean they are separate documents. It is just one document, with each message starting at the top of a new page. This is not the same as printing multiple documents using duplexing, where each new document will start on an odd page.

So to prevent message 2 printing on the back of message 1, you need to print them separately.

I’ll keep that in mind… In our case if there’s a way to select and print a batch that is ideally what we’re after as we do a LOT of printing and printing one at a time is not generally something we want to do as it’s extremely tedious, but I will keep your comment in mind. Thx!