proxy athentification in eM Cliente 6.0.2

I have installed eM Client but I need the proxy configuration to ativate the product. Here in this forum i found a proxy configuration editing “MailClient.exe.config” and I did it but when I try to start eM Client appear this error

the configuration that I am using is:

<?xml version="1.0" encoding="utf-8" ?>






http://myproxy:port"; />






thanks

Hi, can you please click on the “Show error” button and display the error that occurs?
Please copy the error and post it here on the forum.

Is the XML copied from your MailClient.exe.config file? The second error displays a quote about possibly an extra ‘;’ sign on Line 9.

Thank you,
Paul. 

here you have the  Error details:
eM Client (6.0.20648.0)
Windows: Microsoft Windows NT 6.1.7601 Service Pack 1, Framework: 2.0.50727.5477
The following error has occurred:
System.Configuration.ConfigurationErrorsException: Configuration system failed to initialize —> System.Configuration.ConfigurationErrorsException: Name cannot begin with the ‘;’ character, hexadecimal value 0x3B. Line 9, position 59. (C:\Program Files (x86)\eM Client\MailClient.exe.Config line 9) —> System.Xml.XmlException: Name cannot begin with the ‘;’ character, hexadecimal value 0x3B. Line 9, position 59.
   at System.Xml.XmlTextReaderImpl.Throw(Exception e)
   at System.Xml.XmlTextReaderImpl.Throw(String res, String[] args)
   at System.Xml.XmlTextReaderImpl.Throw(Int32 pos, String res, String[] args)
   at System.Xml.XmlTextReaderImpl.ParseAttributes()
   at System.Xml.XmlTextReaderImpl.ParseElement()
   at System.Xml.XmlTextReaderImpl.ParseElementContent()
   at System.Xml.XmlTextReaderImpl.Read()
   at System.Xml.XmlTextReader.Read()
   at System.Configuration.XmlUtil.CopyXmlNode(XmlUtilWriter utilWriter)
   at System.Configuration.XmlUtil.CopyElement(XmlUtilWriter utilWriter)
   at System.Configuration.XmlUtil.CopySection()
   at System.Configuration.BaseConfigurationRecord.ScanSectionsRecursive(XmlUtil xmlUtil, String parentConfigKey, Boolean inLocation, String locationSubPath, OverrideModeSetting overrideMode, Boolean skipInChildApps)
   at System.Configuration.BaseConfigurationRecord.ScanSectionsRecursive(XmlUtil xmlUtil, String parentConfigKey, Boolean inLocation, String locationSubPath, OverrideModeSetting overrideMode, Boolean skipInChildApps)
   at System.Configuration.BaseConfigurationRecord.ScanSections(XmlUtil xmlUtil)
   at System.Configuration.BaseConfigurationRecord.InitConfigFromFile()
   — End of inner exception stack trace —
   at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean ignoreLocal)
   at System.Configuration.BaseConfigurationRecord.ThrowIfParseErrors(ConfigurationSchemaErrors schemaErrors)
   at System.Configuration.BaseConfigurationRecord.ThrowIfInitErrors()
   at System.Configuration.ClientConfigurationSystem.EnsureInit(String configKey)
   — End of inner exception stack trace —
   at System.Configuration.ClientConfigurationSystem.EnsureInit(String configKey)
   at System.Configuration.ClientConfigurationSystem.PrepareClientConfigSystem(String sectionName)
   at System.Configuration.ClientConfigurationSystem.System.Configuration.Internal.IInternalConfigSystem.GetSection(String sectionName)
   at System.Configuration.ConfigurationManager.GetSection(String sectionName)
   at System.Configuration.PrivilegedConfigurationManager.GetSection(String sectionName)
   at System.Net.Configuration.SettingsSectionInternal.get_Section()
   at System.Net.ServicePointManager.set_Expect100Continue(Boolean value)
   at MailClient.Program.Main(String[] args)

Hi again
I found the solution for the error, where I put the proxy name in the end I had a semi-colon, then I remove it from that place.
Now I don’t have errors but with the proxy setting already done eM Client  continue asking me for proxy authentication.

Please help?

Hi again, unfortunately this seems you’re using proxy with authentication, that’s unfortunately not supported in eM Client, the only way how to use proxy with authentication is to use windows credentials, we have a workaround for this setup, but unfortunately if you’re using custom credentials, it is not possible to use eM Client with your setup.

Thank you for understanding,
Paul.

Hi
I understand but could you explain me how can I use eM Client with the proxy authentication using windows credentials.
And if is possible give me some example.

thank you again

Using proxy with windows credentials is a matter of system setup, if you set it up correctly send me an email to mcgregor@emclient.com and I can send you eM Client config file to use the application with this setup.

Thank you,
Paul.