Protocol TLSv1.2 not work

Hi, why can not I use the TLSv1.2 protocol to send and receive messages with IMAP? My hosting does not have the TLSv1.0 protocol enabled for security.

The best security option for IMAP is to use port 993. Check that the security policy is set to Use SSL/TLS on special port (legacy). Port 143 is a less secure option with the security policy set to Use SSL/TLS if available.

For SMTP use port 587 , with Force usage of SSL/TLS

I use this port configuration exactly that it tells me and it does not work with eM Client, but the same configuration I use in the Mailbird program if it works without problem.

The problem is that eM Client does not support TLSv1.2, only support v1.0 and the WHM server disabled it for security.

https://www.mailenable.com/kb/content/article.asp?ID=ME020634

That post is 2 years old. Did you see my comment at https://forum.emclient.com/emclient/topics/the-end-of-support-for-older-tls-versions-in-office-365

I already try everything and it does not work with eM Client, I use the same configuration in Mailbird and it works perfect. It is obvious that eM client has problems with the TLSv1.2 protocols

What is your .NET version? You can find it by typing the following at the command prompt:

wmic /namespace:\root\cimv2 path win32_product where “name like ‘%%.NET%%’” get version

where? My PC or the server I use?

In my PC the version is 4.5.2

The PC. eM Client’s ability to connect using TLS 1.2 is dependent on the version of .Net you have installed.

I have asked one of the eM Client staff to comment on this.

It’s weird, because the exact same configuration that I use in eM Client does not work but in Mailbird it works without problem. I have also tried Office and it works without problem.

I connect to a server that I have with WHM and use this configuration:

SSL Protocols: TLSv1.2

Secure SSL/TLS Settings:

IMAP Port: 993
POP3 Port: 995

SMTP Port: 465

Normally when you can’t connect it is because of one of two reasons.

  1. The security policy is incorrect. For the ports you have listed, the security policy must be Use SSL/TLS on special port (legacy)

  2. Your anti-virus or firewall is blocking the port or application. Disable both and try again.

If that happens then with Mailbird I would not have to connect either but I do it without problem.

The antivirus does not have anything to do with it, because it would block too when I try using Mailbird and Office and that does not happen.

I have already tried several mail clients such as: Office, Mailbird, Postbox, Thunderbird and they all work without any problem using that configuration indicated above. With eM client it is impossible to connect and it does not work for me.

In the end he decides to buy a license in Mailbird because the program never worked. Although both programs have the same exact configuration, eM Client does not work at all, but Mailbird works perfectly.

Hi Alfred,

eM Client supports TLS 1.2 so there is not a problem in this. Rather it seems as an issue following other problem in a specific hash function and other clients might have some fallback feature we don’t have. Unfortunately, without the log file I’m unable to tell you more about it. Could you please send me the Network Communication logs from Menu > Tools > Settings > Advanced > Logging to markosky@emclient.com?

Thank you.
Russel

Not necessarily. The anti-virus or firewall might be blocking the application not the ports. You can’t be sure unless you try it.