Profile picture of contact is low quality when synced

When I set a profile picture for a contact in emClient, the picture quality is very bad when it is synced with my googlemail.com account. However, if I set the profile picture of a contact on my Android 10 smartphone, the avatar picture quality is much much higher.

Is this on purpose or a bug?

Sunday 30 January 2022 :: 1526hrs (UTC +01:00)

There is no difference in quality for my avatars where they are the same, I use
several across different accounts, no matter if eMC, Gmail or here, they are all
as clear as you see here, as they are also on both my iPhones.
The avatars are all generated by gravatar.com, if you are not using this service
it would be an idea investigating.

¡Saludos desde la soleada Sevilla España!

Skybat
emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

1 Like

I have the same problem. Did you find any solution @martin37?

I have started using eM Client in September. Since then I have lost all my high quality Google Contact pictures I’ve been uploading for years.

If the contact has a Google Profile picture it is usualy high quality. If it gets degradated (which happens as well) I choose “Remove picture”, the degradated phone is being removed and the high resolution Google Profile photo comes back.

If I have uploaded the contact photo by myself the degradated photo is synced with my Google account. So the trick above does not work, as I loose my photo for good when I choose the option “Remove picture”.

Is this a common issue? Any solution for that? Although I have already lost most of my high quality pictures so I do not have much hopes :frowning:

@martin37

When I set a profile picture for a contact in emClient, the picture quality is very bad when it is synced with my googlemail.com account.

I agree with @skybat for Profile picture / icon problems, to use the Gravatar site. I also use that and works fine and “no picture / icon quality degradation” I can see using that service.

Also if you have had a Gravatar before and want to update it in eM Client to a new one. Change your Gravatar on the Gravatar website and then in eM Client go to “Menu / Settings / Contacts / General” and remove the checkbox “Download avatars from external sources” and click “Apply” and then “Re-check that box” again and “Apply” which will then force eM Client to d/l the new Gravatar global icon. It can take a little time to update in eM Client so be patient if you do that.

@Doman

I have started using eM Client in September. Since then I have lost all my high quality Google Contact pictures I’ve been uploading for years.

If you go online to your Google account are the contacts high quality pictures / icons ?

If “they are high quality” online, then remove and re-add your Google account using the automatic email wizard setup in eM Client via “Menu / Accounts” which should then fix it.

Failing that you could also try repairing your Google Contacts by “Right Clicking” on “Contacts” directly under your Google account in eM Client, and then clicking “Properties”. Next click the “Repair tab” at the top, and finally click “Repair”. This might fix the problem if the eg: Local Gmail contact photos / icons are out of sync or not updated properly with your account online

Now If the contacts online in your Google account “are not high quality”, then contact Google either via their community forum or via phone, as eM Client (if you are using the default IMAP setup) just mirrors your Gmail account email & contacts etc online.

Also if your Gmail Contact account picture / icons “are ok online” and repairing or removing and re-adding your Google account makes no difference at all to the contact quality, then if you have been doing regular eM Client backups either manually via “Menu / Backup” or automatic periodic backups via “Menu / Settings / General / Backup”, you could then restore a recent backup via “Menu / File / Restore” when you know the picture / icons high quality were ok.

Lastly check that you have the latest version of eM Client as could be you have an outdated version. You can check for the latest versions via the release history page.

Note: If you do update to a later version, backup eM Client first incase of any problems, and close the program before upgrading.