Problem with (utc -7) Timezone from webcal to eM Client

I noticed a display problem with the time zone feature. Using google calendar, if I create an event using the web calendar (or my iPad or phone), when I display that event in eM, the time displays correctly in the month view, but if I open the event details, the time zone box is displayed with the “UTC” time zone selected rather than my default UTC-7 zone.

Note: This topic was created from a reply on the Please add time zone dropdowns with calendar start/end dates topic.

I’ll include the screen shot from the other thread, for completeness:

Please contact me on together with this topic’s url, plus send me exact number of your version.


I am using version 6.0.19714.0 (emailed this also)

To everyone who has this issue please contact me on we have possible fix for this, but it is not currently schduled to be released publicly.

please add link to this topic in email’s subject or in body so I can see on what issue you are responding.


The proposed fix in build 19762 doesn’t work. I get the same behavior as in the screen shot above. UTC time shown on event details page, with correct local time zone on month view.

Then I will need your GData logs, go to tools - settings - advanced, check GData under your account, apply and restart eM Client.

Simulate steps that leads to your issue and after that send logs… to together with this topic’s URL in subject.

then you can turn logging off.


Logs sent. However I found a new problem (maybe should start a new topic). When I tried to send the log files using the “Send Logs” button on the Advanced Settings page, I got the following message. I deleted three attachments that had 0 bytes length and then it was accepted. However, I’m not sure if it was sent properly and has all the information you need.

Fork from:… Please reference the new topic here: Issue while trying to sendemail.…

Any news for this problem? It still persist with the version 7