Problem with synchronization of folders

I am using a mail account. The synchronization doesn’t work properly. In fact I get an error from the client that the process was interrupted, each time I click on refresh. The ports are the ones recommended from the provider, with a SSL/TSL encryption for a specific port (Legacy), 993 for IMAP and 587 for SMTP. The client is also stating that there is no connection neither to IMAP nor to SMTP. I also tried before the Ports from the Auto-Setup, 143 (IMAP) and 25 (SMTP), both settings with and without Legacy.

Have you clicked the radio button & clicked the diagnose button under settings?

If the settings are correct, and you are still not able to connect to the server, it may be that your anti-virus application is blocking the connection. You can try disabling the anti-virus and firewall and try again.

@ Frank James: Yes, the diagnosis says everything is fine. Also it seems that the synchronization works with the settings 143 (IMAP) and 587 (SMTP). But still I always get a notification of an error that the process was interrupted.
@ Gary Curtin: The anti-virus is not blocking the email client, I checked the settings of the program (Firewall and Mail-Virus settings). Stopping the whole program doesn’t help either.

Now it didn’t work anymore at all, so I changed again to 993 with Legacy. I can receive mails now but the synchronizing process isn’t stopping anymore and I still get the same notifications of error.