Problem with rules


I set up the attached rule. Problem is, it is moving EVERYTHING into junk

How do I avoid that?

My basic premise is to filter out junk email (via words in the email) and to forward the remaining valid emails.

Well those words are really common and you can find them in just about any legitimate email you receive.

For example, any email you receive with the word kind in the body is going straight to junk.

Rather you should use words that are unique to spam.

But best is to mark messages as spam in webmail for your email provider. Their server has spam detection, so they will learn from that and they will be able to move similar messages to spam in future.

Unfortunately I cannot do it at the server level.

I tried sending a mail with just the work “hello” and it was moved to the junk folder

It’s not that Rule doing it then.

If the server doesn’t have spam detection, then it could be the Blacklist. Maybe you blacklisted the address or domain. Go to Menu > Settings > Mail > Privacy > Blacklist > Manage Blacklist. See if the sender’s address or domain is in the list and remove it.

I am not in the blacklist, but it must have been the combination of words because with fewer words it works correctly.