Problem with logging into GMail account.

I updated my system from Win 8 to 8.1. When accessing g-mail account instead of logging I return to logging screen

Hi Jacek,
could you please take a screenshot of your issue? I’m afraid I’m not sure which screen it takes you to.
Have you tried removing the account and setting it up a new, or is this when the problem happens?


Hey Olivia,

I too have this error. This is on a fresh install of windows and eM client (new hdd). Here is the screen shot. Java is up to date. I disabled antivirus/firewall. Java is enabled in both installed browsers (chrome and ie).  The error is generated right after inputting the 6 digit code from the Google authenticator (2 step).


My pc is running Win 7. 

This is a known problem which renders emclient useless if you want security. Their only solutions appear to be (1) turn off security or (2) wait until the next version some unspecified time away. The company claims the problem is with GMail’s OAuth2 software (the bit that does the authentication) but you’ll find no problem with other clients like PostBox using the same methodology.

Hi Gary,
I can see you are very upset and I understand, we are not happy about this issue neither, especially since we keep trying to solve it to no avail, but may I please ask you to stop spamming the forums? While Graham in the comments experiences the same 2step verification problem as you, I believe Jacek’s original issue is different because he doesn’t get to the Javascript page.
Flooding his forum thread with unrelated information will not solve your issue faster.
I very much would not like to do this, but if you do not stop with the spam I will have to start deleting your replies.
Thank you for understanding.


Hi Graham,
unfortunately this is a known issue with google’s 2-step verification that we are trying to solve at the moment. Disabling the 2-step verification is the only workaround at the moment. We are very sorry for the inconvenience.


Olivia, I was responding to Graham’s reply, not to Jacek’s original post.
Sorry if it was posted slightly out of alignment,
Yes I am very, very upset by your lack of action. And I want you guys to sort this out. I am not spamming the forums but I am responding accurately to each post about the same issue. I am only replying to relevant posts with relevant information - in no way can that be considered “spamming”. In this way I am informing your users of the situation. If I have said anything inaccurate then please let me know why my understanding is wrong. Yes, my posts keep the issue at the top of the pile: where I can see that you might not like it there, the reality is that these are valid posts responding to the community’s problems. If you were to carry out your threat and delete those replies then you would be compounding the situation by showing the community that not only are you not solving the problem but you’re afraid to have it discussed.

Hi Jacek,
thank you for the screenshot, so the authorization just keeps sending you back to this screen?
Can you check which version of eM Client are you currently running in Help > About section?
Have you tried removing the account and setting it up a new?


Hey Guys, I think we are all working for the same goal here. It might take some time to look at the Oauth2 hand shake process or the called browser settings imbeded in emclient (for java). I am sure the em client staff has put this at the top of their priority realizing the impact of the nature of this problem.
I am trusting they will get to the bottom of it. I am willing to let them do their job. Not everything has a simple push button fix.

Keep on keeping on :slight_smile:

Lambie (Graham)