Problem with auto backup

The automatic backup seems to have stopped working. So I reset it under MENU, SETTINGS, GENERAL, BACKUP to be: periodic backup enabled, frequency 1 day, preserve last five backups and the clicked the ‘save & close’ button. I then restarted the PC but on looking in Task Scheduler later (to set the time of day etc.) there is no eM Client backup task listed.

I’m using the latest version of eMC and have never had a problem within this version. Has anybody any suggestions on how to fix this annoyance?

Paul Reeman

There may be some error.

Start a manual backup by selecting Menu > Backup. Go to Menu > Operations where you can monitor the progress in the Operations tab. If it fails, go to the Log tab and you will find the error there. Typically it is because of insufficient disc space.

If that works, but still fails with the periodic backup, it may have to do with permissions in Task Scheduler, or the item could even be disabled there. Open Windows Task Scheduler and delete the eM Client item. Back in eM Client disable periodic backup and click on Apply. Then enable it again and click on Apply. A new eM Client item should be created in Task Scheduler. If it is still not working after the next scheduled event, you need to enable History for the Task Scheduler item, and then check that after the next scheduled backup has run. There will be some error listed there.

Thanks Gary,

I’ve plenty of disk space so that’s not the problem but I’ll try the other suggestions and report back.

Paul Reeman

I’ve now disabled periodic backup then re-enabled it and then I checked in task scheduler and the task is now back in the list =.

I’ve reset the time and date to start tomorrow at 08:00:00 hours. I’ll wait and check that it works tomorrow and report further.

Thanks again.

Your suggestion about disabling and then re-enabling periodic backup was successful and today’s auto backup worked perfectly. Problem fixed, thanks for your help.

Paul R.