Problem authenticating Google account - Javascript disabled

eM is retrieving Gmail correctly but putting up a message each time it does so about Javascript being disabled in my browser, which is Chrome.
Javascript is not disabled and I’ve also tried different browsers (Firefox and Edge) as my default browser but still get the message.
Seems to be an eM issue rather than browser.
Any ideas?

Do you have more than one GMail account setup, where one is working and one is not? I have seen this problem before, but only when initially setting up a GMail account. I did not see it appear later and still have email syncing going on successfully. :frowning:

One thing you can check is that you have a default browser named in your Windows settings.

Have a look at this thread and see if there is anything there that will help you.

Spot on Gary - My wife’s Gmail account does not generate the same message.
Default browser is currently defined as Chrome (but I have tried naming other default browsers and still get the same message).
Just tried following advice in the link you provided, which involved deleting and re-adding my Gmail account - now I get the Javascript message when trying to add my account!

Hi Gary,
Think it’s fixed.
As I said, adding my Gmail account by choosing Gmail from the options ran into the Javascript error.
So I followed the advice of someone else in the link you provided and selected “Other”, filled in the necessary details and eM automatically detected the necessary POP3 and SMTP settings without generating the Javascript error.
Mail collection is currently working without any weird Javascript message and it has stayed fixed after a reboot.
Don’t suppose we will ever know the cause of the problem,which seems to have surfaced years ago, and thus I doubt eM will ever fix it but that’s life!
Thanks for your help.

It has to do with the way the account is setup as IMAP using OAuth. POP3 does not use that, so there will be no error.

99.9% certain it was POP3 before Gary.

One problem remains - it’s not syncing my Google calendar or contacts and when I try to set up an account to do so I get the Javascript message…

This error is associated with OAuth which is used when setting up GMail as IMAP. Setting up Google Calendar and Contacts also uses this form of authentication.

One thing you can try is to make sure you have a default browser setup in Windows Settings and that it is updated. Go to Settings > System > Default Apps

Also, check that the application has all associations enabled. Select Set Defaults by App. Select your browser from the list and select Choose defaults for this program. Click on Select All and then Save.

Chrome is set up as the default browser (although I have tried others to try and  resolve the problem) and it has all associations enabled.
I wish to use POP3 but the automatic account setup must go for IMAP .
I can create an email account successfully by choosing “other” from the list of email providers on the automatic account creation screen and selecting POP3. However, I then don’t have my Google calendar entries synced.
Where does the fault lay?
I’ve just downloaded Mozilla Thunderbird and that doesn’t have the same issue as eM.

Remove the account from eM Client and close the application.

Remove eM Client from your connected apps and app passwords in your Google settings If you have it, disable two factor authentication.

Open eM Client and add your account.

Still fails with the Javascript error.

Did you disable two-step authentication in your Google settings for that account?

I tried to turn it off all together Gary and I think I succeeded but I’m struggling to find it again in Chrome so that I can doubl-check!

Two-step is in Google settings.

Thanks Gary…Two-step is definitely off.