Print Preview and Print empty

EM-Client 7.1.30794.0, Win7 32bit

Trying to print any E-Mail, even plain text, results in empty preview and empty prints. Changing the printer does not help, however saving as PDF works.

Maybe this started with this version, it worked in the past. I cannot tell exactly when it started as I’m not printing that often.

We have the same issue with Windows Server 2008 R2 64 bit after latest update (7.1.30794.0).
Probably issue with the new Improved print preview…

We have the same issue after latest update (7.1.30794.0) with this EM-Clients Version with Windows 10 Creator-Update. Downgrading to Version 7.0 is not possible. Downgrading to prior Version of 7.1 does not resolve the problem.

Hello all,

Could you check that you have last drivers installed for your printer?
Please let me know if this helped you.

Regards,
Russel

This seems not to be related to the driver, I have several printers and drivers and they all result in empty previews

It really shouldn’t be issues with drivers - the “Save as PDF” button works but “Print” (with e.g Nitro PDF) prints only blank page… The issue persist probably on all our printers (about 15), but I cannot confirm that…

Hello all,

Could you please send me an email with link to this forum thread to markosky@emclient.com?

Regards,
Russel

I am seeing exactly the same issue on Windows 10.  EM Client is at the latest level, and Windows is fully updated.   If I print to a PDF file, then I get what I want, but if I try to print directly to a printer all I get is blank pages.   Has a fix been identified yet?

 

It’s identified, they found it by debugging it in my environment. Also I got a fixed version to check if it worked. As far as I can tell it was caused by that I changed the path to my TEMP Directory in windows settings. So I think this behaviour can only be seen by people who made changes to this. So what you could try is reset them to their default values as a quick fix.
They generate a PDF as preview image and store it in the TEMP Directory. Due to some misspelling it cannot be found afterwards, so the preview is empty.

Too sad they didn’t mention here that it is fixed and when the fix will become available to everybody.

Gruß
Stefan

Stefan,

Many thanks for your detailed reply.   It is exactly my situation as well.   I have changed the default location for the TEMP folder.   I look forward to the fix arriving via a product update soon.