The “To” line in emails begins to pre-populate as I type, as normal. However, only sometimes it allows me to delete old email addresses I don’t want there, and other times it does not. Further, it does not always order what pre-populates alphabetically; it seems to be ordering them alphabetically within groups of some kind. I can’t figure it out. Any help appreciated.

These addresses come from two locations. One is your Contacts, and I think those are the ones that you are able to delete. The others are from the recipient history, and you will need to delete those by going to Menu > Tools > Settings > Mail > Compose > Recipients History.