Please Help OAUTH Microsoft problem

Hi Team,

I have also raised a ticket but keen to get this resolved ASAP please.

EMCLIENT User for years love it.

Major issue and I have tried everything. It appears that EMCLIENT is sending a different OAUTH link on just this particular computer rather then others where I have tested this over and over and it works fine.

Add account, outlook account, add email, when it is time to validate with microsoft on all other computer it is not a problem I login and validation happens.

However, on this computer WINDOWS 10 fully updated, EMCLIENT sends the link which is different and microsoft does not recognize the email address…related to not being office 365 perhaps.

Here are the links below… please help… I have repair installed EMCLient and also used multiple browsers the link is definately being setn via emclient to OAUTH verify.

Thanks,

Clinton

https://login.live.com/oauth20_authorize.srf?response_type=code&client_id=e9a7fea1-1cc0-4cd9-a31b-9137ca5deedd&redirect_uri=com.emclient.MailClient://oauth&[email protected]&scope=wl.imap+wl.offline_access+wl.activesync+email+openid&code_challenge=1f7Pr4wA5fQW0jFwAdDFDaDHmPxYAo2W2B9czUJshOg&code_challenge_method=S256

https://login.microsoftonline.com/common/oauth2/v2.0/authorize?response_type=code&client_id=e9a7fea1-1cc0-4cd9-a31b-9137ca5deedd&redirect_uri=com.emclient.MailClient://oauth&[email protected]&scope=https://outlook.office.com/IMAP.AccessAsUser.All+https://outlook.office.com/SMTP.Send+https://outlook.office.com/EAS.AccessAsUser.All+offline_access+email+openid&code_challenge=-H_ISWmVWEuyr-NdiX4L6y-6Oe8c4aigU5EpPdtZnb0&code_challenge_method=S256&sso_reload=true

The microsoft online link above is the one that emclient uses on all other computers but this one and that is the one that works.

The email address is:

Are you running version 9.2.1628.0 ?

yes all computers have the same newest version 9.2.1628.0 installed. Thanks.

sábado 11 marzo 2023 :: 1713hrs (UTC +0100)

I checked both of the links after first changing the email address (it would be better to blank out your address before posting), neither of the links work for me stating I do not have a Microsoft account, I tried on Win 11 & Win 10 and I do have a Microsoft account.

I am sorry I can not suggest a solution, presumably you have tried, as I have, cleaning the browser cache and rebooting, all to no effect.

The only thing I can think of is: did you or your company IT department have anything to do with this particular computer?

Other than that I am sorry I can not help, so unless someone on the Forum can, I guess you will need to wait for VIP support, probably Monday at earliest.

¡Buena suerte!

skybat

¡Saludos desde Valencia la soleada en España!

[email protected]

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

Thanks Skybat, Yes I did try all of that.

And I changed the email address as well :slight_smile:
Which is why it might say that. The topic to VIP was the actual email address.

Thanks… It is weird worked on all of the other computers.

No different I was the IT person who installed the others from scratch lol.

Thanks,

If you mean Add Account > Mail > Outlook, don’t. Use the automatic setup instead.

But before you do that, revoke the oAuth access in the Microsoft settings for that account. Then a new token will be created from scratch when you add the account in eM Client using Add Account > Automatic Setup. Make sure that during the web browser part of the account setup, you authenticate using the correct account credentials.

Also, as it is Windows 10, if you have enabled TLS 1.3, it won’t work. TLS 1.3 is not compatible with Windows 10, so you will need to disable it again.

Hi Gary thank you. I will try what you suggest. But some feedback for you.
The same EMCLIENT with the newest update on a seperate Windows 10 machine installs and runs without a problem. Also Automatic setup does not seem to work, I left it for an hour and no joy…I used the outlook.com procedure on 3 other computers and no problem at all. Thanks.

TLS 1.3 could be responsible for that as I said before.

But depending on what is not working, it could also be your web browser. If you don’t have a default browser set in the OS, then it is not possible to initiate the authentication. Maybe set a different browser as default, then try the automatic setup again. Or, if you are authenticating in the browser, but then it is not going any further, that is either the TLS issue, or you have blocked popups in your browser so you are not seeing the option asking if you want to go back to eM Client.

1 Like

Hi Gary,

I have tried incognito mode.
Opera
Firefox
Edge
Chrome

Same issue, the link that is coming out of emclient is taking me to the reisdential version of OAUTH2 and not the OFFICE 365 version.

One is using microsoftonline.com

The other is using live.com <<< that one doesn’t work as the account does not exist.

I have also searched the registry.

Pictures as attached. The OAUTH Link has to be the microsoft online one… then it would work. It worked as a test on the same PC with a cometitors OAUTH 2.0

Here is the correct one…

@markketplan

The same EMCLIENT with the newest update on a seperate Windows 10 machine installs and runs without a problem.

If you have got the correct Microsoft email address in the auto wizard setup and removing the token from that Microsoft account makes no difference, and changing browsers also makes no difference, then sounds like you have some type of Windows 10 related issue either with the profile on this particular computer , or a Registry issue, or a problem with the Win 10 OS itself.

So if this email account was working previously ok on this computer, try doing a system restore back to a date before the problem started which should then fix the problem if it was registry related issue.

Failing that try creating a new test Win 10 profile incase the profile is screwy in some way.

Lastly if that still fails, you may need to either then restore a working backup snapshot image of the computer when it was working (if you do image backups) regularly, or save your profile files and do a clean install.

1 Like

domingo 12 marzo 2023 :: 0454hrs (UTC +0100)

We just got back from a show in Madrid and having been on the Forum whilst on the AVE, as it is not now worth going to bed I see you still have the issue, so…

First, with this correct one, have you clicked next and followed the various options that should be presented by Microsoft moving to the next with failures?
And following on from the @cyberzork suggestions, before, if you decide as a last resort to reinstall the OS, perhaps it might be worth running:

dism.exe /online /cleanup-image /restorehealth
THEN
sfc /scannow

Both from an elevated cmd prompt

Just a thought…!

¡Buena suerte!

skybat

¡Saludos desde Valencia la soleada en España!

[email protected]

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

2 Likes

Hi Team,

Thank you to SKYBAT and Gary.

I have solved the problem. I spent a considerable amount of time testing various things including removing Microsoft credentials of all the office logins I have.

I also performed the DISM command and SFC command listed above.

But here is what worked:

  1. I chnaged the directory name of EMClient to Emclient 2 (the one located in Roaming)
  2. I used Geek Uninstalled to remove EMCLient in full and all registry entries.
  3. I then restarted the computer
  4. I then reinstalled EmClient
  5. I then changed name of directory back to Emclient
  6. All my previous accounts were listed, so I added the account in question above
  7. OAuth 2 verified the correct link this time.

All is well.

Thanks for the great support team much appreciated!!!

Thanks for the details of how you resolved it. :+1:

1 Like

domingo 12 marzo 2023 :: 1431hrs (UTC +0100)

Great you fixed the issue.

I probably should have mentioned, however, I had a lot of issues when I first started using eMC and eventually moved the complete installation of eMC, everything, database, backup, Roaming, to a separate dedicated partition (nothing else only eMC) on my #1 SSD, like this:
(E:) eMC ->Program Files →
eM Client
->… cs da de Dictionaries Mailclient.exe .dll .xml …etc
→ #Data# →
#Attach# … Sub-folders by Type of File / Client Name / etc
#Backup# … 5 Backup Files timed for 1900hrs daily
#Calendar# … All my ICS files
#Themes# … Personally created Themes
eM Client_DB … Database #1 (my default that includes #2, with #3, #4, #5 excluded)
… Database #2 (Compucall Holding)
… Database #3 (Legal UK)
… Database #4 (Legal Spain)
… Database #5 (Personal)
Alternative Database is loaded with this parameter: /dblocation PATH otherwise default will load
And if the parameter folder does not exist eMC will create it with a new empty Database

I don’t know what difference it makes - everything is instant performance though I am fortunate to have very high spec computers, plus I do not remember the last time I had any sort of issue.

¡Buena suerte!

skybat

¡Saludos desde Valencia la soleada en España!

[email protected]

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

I am struggling with the same problem and tried your solution. It did not work for me.
Have been happy with EMclient for many years, to combine online Outlook accounts with Gmail accounts, but outlook just stopped … :worried:
PS, the uninstall using Geek also removed the EMClient2 folder. Perhaps I should have followed exactly what you wrote and I should have renamed it to “EMClient 2”