Plaintext message padding

I’d like to see a feature, where you can define amount of padding on each side to plaintext messages.

I love the theme editor, so I can change the message background to a lighter color with the dark theme. And I prefer the dark theme without message background being dark, which is preventing readability problems with some emails, when images are not loaded, or for some other reason the text is black/dark.

Though one problem here is, that plaintext messages are displayed very close to the edge of message panel, and it makes the text output seem confined and it’s more difficult to read.

Normally the MessagePanelBackground is same color as MailBackground (or close to same), so that gives some padding to the text, but when those elements have totally different background color, you get this issue.

I thought I would miss a setting for the padding of plain text messages as well, but my plain text messages actually do have a padding. I have one message that looks like yours, but that one has a simple HTML format. Could you look at the source of the message in your screenshot to check whether it is really plain text, or possibly plain text and HTML, and eM Client shows the HTML formatting here?

Yes, that is a plaintext message, you can see that in the source and also in the content-type header.

The padding problem also happens with HTML formatted messages (i.e. the notifications from this forum). So, maybe there needs to be a padding setting for all messages.

The padding is already there, so no need to change it. You can see it in your screenshot. It is the space between the vertical line that is the edge of the message preview and the left text border.


So I am not a theme editor, but maybe you are only specifying the text background, and not the message background.

I have eM Client on my PC and on a laptop and was surprised to see that the PC shows messages with padding, while the laptop does not. So I checked the settings in detail, and the difference is that there is no padding if you enable conversations, while there is padding if you disable them (Settings > Mail > Read > Conversations).

Do you confirm this?

I agree with @hezeri that it would be nice to have the padding also if the conversations view is enabled.

1 Like

This is what I tried to explain in the original post. To change that “padding” it would also change the background of the top part. And I’d like to avoid that. I’m trying to create a contrast between email content and email metadata.

All of this is a same UI element. And it’s background is changed by changing “MessagePanelBackground” value.

So the message background clearly shows the padding. But if you just change the text background that is something different. There is no padding in the text. If the first letter starts at 12px, the color starts at 12px. If the first letter has padding to make it start at 24px, the text background color will start at 24px.

This is true.
In conversation view there’s no padding, and when I disable conversation a padding is added.

I cannot confirm that. It appears the same regardless of conversation view.

Here’s a screenshot without conversation view. The padding is slight, but it exists. And this would be enough to not drive me nuts when reading the message. :slight_smile:

1 Like

@Gary, your screenshot with the red arrows in your message above shows precisely what @hezeri refers to.


There is no white / light grey space between the border of the message body and the first word “Hello” or the word “News”. I don’t have this either when the conversations view is enabled, but there is a padding within the message window if the conversations view is disabled. This looks a lot better.

Just to show another plain text example:

With conversations view enabled, a plain text message looks like this:


With disabled conversations view, it looks like this:


In the second case, there is some space before the first word in each line (and actually above the first line).

1 Like

Agreed, I’m trying to setup the same flow and am also annoyed that there is no padding w/ my altered dark theme w/ white message body background.