Opening links in email using eMClient for iOS

When I click on a link within an email using the iOS client, I get “This web page could not be loaded” and “Due to an internal error, this web page could not be loaded”.

The mail service I’m using is Outlook from Microsoft.

I don’t have this problem with any other email client on iOS.

I can’t replicate that problem with my iPad using the latest eM Client V10.0.2080 just released a few days ago from app store & running on iOS V17.4.1

So if you already have the latest eM Client mobile app version, suggest to try removing and readding your Outlook account and see if that fixes it.

Apart from that you may need to remove the account and completely uninstall and reinstall the eM Client mobile app.

If still happening, update this thread with an example url link (if it’s public) and we can test it on iOS.

I’ve tried it on two different iOS devices (iPhone and iPad) and the behavior is the same, I get the same error.

I think it maybe related to the fact that Outlook mail uses something called “Safe Links” which is a security feature to gaurd against malicious links.

When you click on any link, it must go via a Microsoft service which checks the link is safe before sending you to it.

I don’t have this problem using this account with the Outlook App for iOS or the built in Mail app on iOS.

When you tried to repllicate it, was it an Outlook Mail account that you were using?

Yes tried with my IMAP account. I also have a Microsoft IMAP account and both open any url links from within any email in those two accounts.

Do you have a public Outlook url email link we can test ?

If i forward the email to a gmail account, the link works from the gmail account on the same device.

Its not that easy to provide a URL as Microsoft changes the URL to add its “Safe Links” feature.

Do you have an email address I could forward the email to so you can check it yourself?

Its just an email from Linked In with jobs. Clicking on any of the job links gives the error.

Try setting eM Client iOS app to “Open links in external browser” as per @Gary advised in another thread and see if that then works ?

That sounded promising, but unfortunately has not resolved the issue.

I appreciate your help though. Thanks for your efforts.

What browser did the URL open in ? Maybe try setting a different browser as the default.

Also when you press the link to open it, does the complete URL select or only partly ? Hold your finger on the link in and see if it is all 100% being selected.

It opens in the default browser which in this case is Safari.

Try setting Chrome as the default browser and see if that works ? Just to see if it’s a restriction in Safari.

Apart from that if still won’t open in Chrome , then send it to [email protected] to check out.

Tried Edge as the default browser, I don’t currently have Chrome. Same error. I will emal as suggested.