Office 365 authentication problem

Hi, I’m trying to configure emClient with Exchange Online ( Office 365 ) but I cannot login using my credentials.

I’m sure that credentials are right but the client show me this error:
The server was found, but authentication failed. Check the email address and password

The version of emClient is 6.0.21372.0

Thoughts?

Thank you very much

Hi Davide, this error suggest wrong credentials are being used to authenticate with the server. If you’re absolutely sure the credentials are correct, this may also be caused by a security element in your network, such as firewall or proxy software on your computer etc. in case you’re using any security software on your computer, please try to temporarily disable these options and try again.

Thank you Paul for your support.

I’m absolutely sure that credentials are correct and Yes, I have a Firewall on the network but, for the client where I’m testing emClient, all ports are opened.

Can you be more specific on which services/ports I have to check?

I’ve removed the Firewall from network but the problem is the same… :frowning:

Hi again Davide, is it possible you’re using domain names in order to login to your Exchange account? Please try to update your eM Client to this release, http://www.emclient.com/dist/v6.0.22065/setup.msi and check if the issue persists.

If it does, please try to setup your Exchange manually rather than using the automatic setup. To setup the exchange account manually, please switch to the “Mail” tab below the automatic setup, select Exchange and proceed with the steps.

Hey Paul,I use my complete email address to login on Exchange Online ( username@mypublicdomain.ext ).

I’ve updated emClient with your attachment but the problem is the same, and I have tried using the automatic setup and the manual configuration but same error message.

Cheers

Any news about that?
I’m available if I can help you to identify the problem.

Hi Davide, I’m afraid there must be an authentication issue with your mail server, can you please send me an email to mcgregor@emclient.com with a reference link to this forum topic?

Thank you,
Paul

Hi Paul, I’ve fixed it …

The problem is that I’m in a SBS 2008 environment and the Autodiscover forced the internal resolution, now it works fine! :wink:

But another problem now …
I need to allow an account to send as a Distribution Group.

I’ve already setup delegation on Office 365 to allow the account as a sender and it works using OWA.

In emClient I’ve added the Group in the delegation section ( “Accounts you can access” ) but, after added it and pressed OK nothing happen ( adding a user account it works ).

Thoughts?

Hi again Davide, thank you for reporting this it seems like when setting up delegation, the delegated account won’t automatically appear in the list of aliases available for sending out messages.

You should however be able to setup the delegation in eM Client, right click your account in the left pane and select delegation, change who can access your account and add your other accounts to the list. After you do so, you also have to add the address to your aliases under your account settings.

Navigate to Tools > Accounts > Your Exchange account > Aliases.

Hope this helps, we’ll be working on improving this behavior in upcoming releases.

Ok thank you very much :wink: