object reference not set to an instance of an object error is constantly happening

this started a few days ago.  keep getting this object reference error even though i think em client is working correctly, just getting this annoying error and no clue why.  any ideas?

If this is an IMAP or Exchange account, you can remove the account from eM Client, then add it again. See if that makes any difference.

As always, before editing accounts, or doing anything drastic, make a backup using Menu > File > Backup.

tried it, didn’t work

After removing then re-adding the account, is this happening after adding a new item? The redacted location could be the clue.

Not sure what you mean by adding an item?

The error indicates that there is an item being uploaded to a folder on your account. Maybe it is a contact, an event, a message etc. The redacted location in your screen shot will show what item is being added.

it is saying there is an error uploading an item to my gmail folder. but it is not saying what the item is.  If I could find out what specific item it’s referring to I would just delete it.  the only thing i blocked out in my screen shot was my email address.

Was part of that address not also the folder location? Otherwise you have a very long email address Frank.

With GMail accounts, one option is to remove the account from eM Client, then add it again. That will provide a complete new sync with the server and the error should not appear.

the folder name is my email address/my email address.  gary all you are doing now is suggesting i do the same thing you suggested in your first comment on this string.  i already did delete the account then add it again.  Anyone else have suggestions?  If this keeps happening bye bye em client, you were fun while it lasted.

OK, that makes sense now. 

I have a solution for you, but you don’t like my suggestions. That is OK with me and I won’t comment further on this thread.

Hi Gary, maybe you can help me then. I have been using eM Client for a couple of years now with very few problems, but after updating to the latest version (8.0.1287) (4ffdc70), I now cannot attach any photos, documents or downloads etc. to outgoing emails. The same error message appears-“Object reference not set to an instance of an object”. I tried going back to an earlier version of eM, but it seems I’m not permitted to :). Then I tried going back to an earlier point in time with the computer, but it seems that this does not work on email programs. I have Windows 8.1 64 bit. Can you help please Gary, I tried pulling my hair out, but there is very little left. Thanks, Ian. 

Hi Ian.

I am not seeing that error with the beta version, but then betas are a bit odd that way. Best option is to first update to the latest beta in the Release History, (there was one just posted) and if that does not help then contact eM Client directly. Send them an email at testing@emclient.com and they should respond quite quickly.

The problem with going back to version 7 is that the version 8 database is not backwards compatible. That is not a problem if all your data is synced with your server, so just uninstall version 8 and select to delete the database directory when asked. Then install version 7, setup your accounts and you should be good to go. But if you have messages, events and contacts in Local Folders, you will have to export those before you uninstall. 

Or if you have a recent backup from version 7, uninstall version 8 deleting the database directory when asked. Install version 7 and do a restore.

All previous released versions are available in the Release History.

OK Gary, thanks for that, I’ll try those options later when I have time and let you know what happens. Cheers.

Back again Gary. I eventually got around to trying what you said. I tried the latest updated version but still no go, attachments wouldn’t attach. So I tried your second suggestion, I exported my local folders and went back to version 7.2.38732.0. It seems that the trouble I had before going back to the earlier version was me not clicking on the ‘delete the database directory’, mainly because I couldn’t see it hidden under the pane showing the uninstallation progress bar! So there’s a tip for everyone. Move that pane so you can see what’s happening.
So the version I have now Gary dates as March 20th which I am quite happy with because as I said, I had very few problems with the one I had until I updated to the Beta 8 version. Whatever is causing the problem with that update is something away beyond my knowledge and I just can’t be bothered trying to track down what the problem is. It’s possibly a problem in this computer, I don’t know, all I know is I need a good reliable email program which eM Client has been for me for about three years. I’ll see how this goes Gary and I won’t update in the future. I truly appreciate your help with this, forget about people with a bad temper and attitude, that just won’t solve any problem. I’m not sure where you are Gary but thanks ‘Mate’ from Australia and all the best, Cheers, Ian.

I am also having this same problem after upgrading to version 8. Fortunately I have another mail client to use when sending attachments. I like the new changes in version 8 and will wait for a fix to this issue or will try re-installing.

I just installed eM client for the first time, but when I try attach a file to an email, I get, “File “C:\Users\D\Desktop\guy1.jpg” couldn’t be added as attachment due to the following error: Object reference not set to an instance of an object.”

Hi Ron,

This is a know issue in their cloud attachments feature. Try this workaround:
Menu>Settings>Mail>Compose, scroll down to the Cloud Storage Attachments and set the action to ‘Add as regular attachment’.