Object reference not set to an instance of an object Attachement

I keep getting this error any time I want to attach a file to any email since upgrading to v 8.0.2751. Any one else seeing this, or have a solution. It’s irritating having to go to my webmail (gmail specifically) just when I need to send an attachment.

Forwarding an email with attachment no issues. Things I’ve tried so far:

  • Repair install
  • Database checked by EM client
  • Restore DB
    Cannot find a way to rollback to previos version which had no issues.

Thanks in advance!

Ok… after a little fiddling, found a solution. Go to:
Settings > Mail > Compose > Cloud Storage Attachments
Change this setting to: Add as a regular attachment

This seems to have solved it for me.


Mine is set to Always Ask and it’s by default

Interesting, what version / OS are you using?

I’m on version 8.0.2703 on Windows 8.1 and it has a drop down menu to select other options.

I have the EM Client Version 8.0.2703 running on Windows 10 Professional.
I can drag and drop my file in the mail no issue when composing.

Ah, that’s better than I had before. I couldn’t even drag and drop attachments :slight_smile:

Brilliant thanks for your persistence !

Thanks for this!
solved it for me too

Thank you!!! You have just saved me hours of frustration x

Thank you for this, I was about to re-intall version 7! :grinning:


I have been updating my version of eM Client as and when and have also noticed that I can no longer attach files of any type as I always now receive this message

Windows 8.1

Thanks to PR_Dude for the Fix