Not showing time in received column

For older messages I do not see the time they were received, only the date. Can that be fixed?

Hello Alexander,

This is possible in the single-line layout when the conversation mode is off. If you don’t see the date column, you can set it with a right-click on the toolbar > Columns config. > adding “Received” to the list.


This is the same for me. Todays messages show time, yesterdays messages show date only.

How can i show date & time for each email in the Received column, like Outlook?

Whoops - it is right here in the preferences: “Show full date”


Yes, this is an option on the Mac version. It is different on the PC version.

In order to really help, the option is in Menu -> Settings -> Mail -> Read -> Message list

It would great to set it by default, first thing I had to do when I installed the new client is to come to forums to look for solutions.
Just installed it today I had the problem

Thanks for finding the setting. Somehow I missed it in the Windows version settings. :wink:

Fortunately the option is there if you want to enable it in the message list, and it is always there in the message preview regardless of your settings. But by default, when browsing messages from two or three years back, is the time really important?