Not able to add Gmail account in my em Client

I have installed em client, but I am unable to setup my gmail account, after adding gmail account it shows error ‘An attempt to connect to …has failed this could be caused by the server unavailability or incorrect settings’.

This error is coming from last 2 days even after multiple attempts to connect the gmail account.

I have checked all the IMAP and SMPT settings also, all looks fine.

I am able to add my yahoo account successfully.

Any suggestions or am I missing something here or em Client does not work with Gmail?

Thanks

See if this will help, from eM Support:

Disabling the Avast Mail Shield worked initially and allowed eM Client to connect to Gmail via IMAP. However, now I can’t send or receive through the eM Client account connected to my gmail account. Disabling Avast altogether makes no difference.

Any ideas?

Remove the Gmail account from eM Client and then add it again. See if that makes any difference.

Or go to Menu > Operations and look for any errors in the Log tab.

Yes Gary. Deleting and recreating the Gmail account [of course exporting any files I needed to keep first!] got it working again. But after a few minutes, it stopped both sending and receiving any emails. So whatever Avast was doing - and I tried all different settings to disable scanning mail - it was still interfering with the operation of the Gmail account. So I uninstalled Avast altogether. I think that’s finally done the trick. Thanks for your help. Robert

2 Likes

And there never were any errors in the Log.

Sadly, uninstalling Avast didn’t solve the problem. After deleting and recreating the Gmail account, I got both incoming emails and was able to send. However, after a period of time - perhaps 30 minutes - I got no more incoming but I can see I have some new emails in my Gmail folder by looking at webmail. So they have stopped being downloaded again from Gmail to eM Client. And when I send to my Gmail account from eM Client, they don’t appear in my Send folder and I don’t think they are being sent at all. So something else is interfering with my Gmail account on eM Client.

@Robert_Sterry As you have already removed and re-created your Gmail account and already disabled Avast Mail Shield and still have same issue, then does still sound like (something is still running resident in the background) on your computer interfering with EM Client.

First obviously make sure you have the latest version of EM Client installed via the version history webpage, and update if needed. https://www.emclient.com/release-history

Next if you already have the latest version of EMC installed, then I would next try disabling “all background tasks” on startup and reboot to see if EMC then continues to work ok with Gmail.

If EM Client then continues to work ok with Gmail, start enabling the background tasks (one at a time) and reboot in-between till you find which background task that is causing the problem.

If disabling all background tasks makes no difference at all, then re-enable all background tasks, and try starting up in “Safe Mode”. Sometimes starting up in Safe Mode is the only way to test where the problem lies.

2 Likes

Enter Google mail suite security options and enable less secure apps option.

That is only required when using POP3. Kumar and Robert said they are using IMAP.

My problem is now solved. Curiously, once I uninstalled Avast, eMClient eventually fixed itself - although it took 12 hours to do that. I didn’t need to apply the fix to ‘try disabling “all background tasks” on startup’. When I went to bed it wasn’t receiving any Gmails but when I checked the next morning, they were coming through fine. I did get some very odd messages in my Sent folder from nobody@invalid.invalid to undisclosed recipients. These were coming in at the rate of 9 every minutes for several hours. But these also stopped and I just deleted them. They haven’t appeared since. Thanks heaps for your help. Really appreciated.

1 Like

It’s also valid for IMAP. This should be done before creating a google account im EM client.

No it is not. IMAP works just fine with that setting disabled.

Absolutely not. Please do not give nonsense and dangerous advice on this forum.

Dangerous for what reason ???

You are incorrectly advising users to use less secure settings.

I wonder why I never had a problem with G suite using em client.