No synchronisation between em Client and Google Calendar

I am using em Client (em Client Ver.: 9.1.2109) for years to my satisfaction, among other things to synchronise my appointments between my PC (-> em Client Calendar) and my smartphone (aCalendar) via Google Calendar.
About two weeks ago, the synchronisation between PC and Google Calendar stopped working; the synchronisation between smartphone and Google Calendar continues.

I installed em client (and data backup) on a second (similar) computer, with the result that synchronisation occurs properly.

On the first computer, I uninstalled em Client and reinstalled it, as well as uploading the data backup.

The result: still no synchronisation between PC and Google Calendar. I can see from the log files (please see attached files) that the authentication is aborted, but I lack the insider knowledge to recognise the reason for this.

I have also not found a solution in the support (e.g. “Gmail won’t load or sync”).

I request you to help me in troubleshooting.

File “auth” (with modified email-adress):
16:20:59.887|00C| eM Client 9.1.2109+9967b9369e (Windows)
16:21:03.105|023| ReacquireCredentials_Oauth_AccessToken my_emailadress-gmail.com]()
16:21:03.105|023| Access Token = Expiration = 01.01.0001 00:00:00
16:21:03.105|023| Refresh Token = 1//09VQYabJviitjCgYIARAAGAkSNwF-L9IrE00jP5wU-hJRvzWQqaVeXBer2jdyrEa6hFdwf4YGmpm55TVa5gps1ffhqBuVOGIwbYw
16:21:03.105|020| ReacquireCredentials_Oauth_AccessToken my_emailadress-gmail.com]()
16:21:03.105|020| Access Token = Expiration = 01.01.0001 00:00:00
16:21:03.106|020| Refresh Token = 1//09VQYabJviitjCgYIARAAGAkSNwF-L9IrE00jP5wU-hJRvzWQqaVeXBer2jdyrEa6hFdwf4YGmpm55TVa5gps1ffhqBuVOGIwbYw
16:21:03.112|009| RefreshAccessToken my_emailadress-gmail.com]()
16:21:03.287|009| RefreshAccessToken my_emailadress-gmail.com]()
16:21:03.373|023| ReacquireCredentials_Oauth_AccessToken my_emailadress-gmail.com]() = Abort
16:21:03.373|023| Access Token = Expiration = 01.01.0001 00:00:00
16:21:03.373|020| ReacquireCredentials_Oauth_AccessToken my_emailadress-gmail.com]() = Abort
16:21:03.373|020| Access Token = Expiration = 01.01.0001 00:00:00

File “my_emailadress-gmail.com Google calendar”
16:21:03.050|009| eM Client 9.1.2109+9967b9369e (Windows)
16:21:03.050|009| Account’s UID is 11ee06ce-fa92-4dcf-baf2-acac97962aac
16:21:03.050|009| AccountBase.ChangeOnlineState : State changed to ONLINE due User
16:21:03.382|020| Exception: MailClient.Accounts.AuthenticationAbortedException: Authentifizierung abgebrochen
16:21:03.382|020| at MailClient.Protocols.Gdata.GenericGapiCommand.Execute(WorkerStatus status)
16:21:03.382|020| at MailClient.Commands.Command.Process(WorkerStatus status)
16:21:03.384|00F| AccountBase.ChangeOnlineState : State changed to OFFLINE due LoginCanceled

File “my_emailadress-gmail.com Google Settings”
16:21:03.050|010| eM Client 9.1.2109+9967b9369e (Windows)
16:21:03.050|010| Account’s UID is 11ee06ce-fa92-4dcf-baf2-acac97962aac
16:21:03.050|010| AccountBase.ChangeOnlineState : State changed to ONLINE due User
16:21:03.382|023| Exception: MailClient.Accounts.AuthenticationAbortedException: Authentifizierung abgebrochen
16:21:03.382|023| at MailClient.Protocols.Gdata.GenericGapiCommand.Execute(WorkerStatus status)
16:21:03.382|023| at MailClient.Commands.Command.Process(WorkerStatus status)
16:21:03.384|010| AccountBase.ChangeOnlineState : State changed to OFFLINE due LoginCanceled

Try Repairing the Google Calendar in eM Client.

Click the Calendar icon at the bottom left of eM Client.

image

Then “Right click” your “Gmail Calendar” and “Click Properties” at the bottom

Next click the “Repair” tab at the top and finally click “Repair”. This will take time as eM Client has to rebuild the local calendar cache etc

If the Google Calendar still won’t sync in eM Client to your online calendar, I would then remove the whole Google account in eM Client and then Re-add your Google account "via the automatic wizard at the top via “Menu / Accounts”. Before removing first backup eM Client via “Menu / Backup”. You can see when the backup is completed via “Menu / Operations”.

Note:- Also recommend “to remove the eM Client token” in your Online Google Security “Third Party allowed apps allowed apps” sections “before readding your Google account” so its all new.

Security (google.com)

The above procedure didn’t help.
I continued to test without the firewall and the virus programme, again without success.

Are there any other measures to restore the authentication?

@norbert756

ReacquireCredentials_Oauth_AccessToken my_emailadress-gmail.com]() = Abort
16:21:03.373|023| Access Token = Expiration

When you removed the eM Client OAuth token from your Google account, and then removed and readded your Google account via the automatic account setup wizard, did your browser at that end of the wizard popup to allow eM Client access to your Google account?

I’m currently testing eM Client as a replacement for Outlook, but i’m having the same issues, the Google Workspace calendars do not sync. this would be a deal breaker as i like the app so far. I’ve tried the above suggestions.

@norbert756

Apart from “making sure to clicking allow in the browser to give eM Client access to your Google account” with a OAuth token at the end of the automatic setup wizard as mentioned previously, there is also also later release versions of eM Client you can try which might fix that issue.

I notice you have version 9.1.2109. There is now a newer 9.2.2093 for (Windows) & 9.2.2054 for (Mac).

See the eM Client release history page.

If you do try the new update, backup eM Client first and close eM Client before updating.

Dear cyberzork
I deleted the emClient access permission at Google, installed the current version 9.2.2093 of emClient, imported the data and gave emClient access to the Google account again. When I enter an appointment in the calendar of my smartphone, it appears seconds later in the Google calendar. emClient indicates that the connection to the Google account has failed.

Screenshot 2023-09-10 12.59.34

@norbert756

I deleted the emClient access permission at Google, installed the current version 9.2.2093 of emClient, imported the data and gave emClient access to the Google account again. When I enter an appointment in the calendar of my smartphone, it appears seconds later in the Google calendar. emClient indicates that the connection to the Google account has failed.

I see your Google Calendar error message in your screenshot appears to be: “The attempt to connect to @gmail.com failed. This could happen due to temporary server unavailability or incorrect settings. Please check the settings or click the warning icon to try again”.

Can you send and receive email ok (apart from the Google calendar), or does the email also fail ?

Dear Cyberzorg
I normally only have calendar sync via Google, emails from other accounts.
Now I have tested the following: emClient data backed up, emClient uninstalled, access rights Google account deleted, emClient reinstalled with Google account access to emails, calendar, contacts. Access rights of emClient to Google are set up from emClient. Result: the same message “The connection failed …”, no access to the Google account.

emClient reinstalled with Google account access to emails, calendar, contacts. Access rights of emClient to Google are set up from emClient. Result: the same message “The connection failed …”, no access to the Google account.

Ok so you also cannot even access emails or contacts with eM Client. So nothing is working.

You are using the latest eM Client version and you have already tried removing and readding your account and given eM Client access again to your Google account via the browser popup at the end of the automatic setup wizard.

Also you have already tried disabling your optional firewall and antivirus program as you mentioned previously and still getting the message no access to your Google account which is strange.

Do you run any optional VPN? If you do try also disabling that as well to test.

Also have you also tried powering off and on your Internet Modem / Router and any internal Switches etc? If you haven’t try do that just incase you have any physical connection issues.

Do you have 2FA / 2Step verification setup in your Google account security section? If you don’t have 2FA enabled, try turning that on in your account as might be something to do with that.

I do use 2FA / 2step verification in my own Google account with eM Client and it works fine.

Apart from that “if you already tried with 2FA verification turned on” and still getting the message no access to your Google account in eM Client, I can then only presume you have some other program installed locally still interfering with eM Client or you have some sort of actual Windows or Mac OS issue.