No spell check in quoted reply text

Auto spell check works on new emails but if I reply to an email the spell check only works on the text written above the quoted original email. I use the “old method” of inserting answers into the original quoted email but this new text does not get picked up by the spell checker.

Auto spell check is ticked.

Spell check (F7) does not pick up the spelling mistakes there either.

I used the same test word above and below the quoted reply text

What is missing is the wavy red line under the misspelt word. If I right click on the misspelt word I get the menu with suggested corrections.

Any suggestions?

jueves 01 septiembre 2022 :: 1615hrs (UTC +01:00)

Hey@gopher

I have just checked with purposely inserted wrong spelling and it works fine for me across Spanish, Portuguese & Spanish.
Have you tried downloading dictionaries ?
I presume when you press F7 you have a pop-up with mail to be checked inserted.

¡Buena suerte!

¡Saludos desde Valencia la soleada en España!

skybat

emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

Spell check works OK - except within the email which I am replying to.

I have tried to demonstrate it here with a simple example. The phrase This is the original message in italics for clarity is quoted (indented) but the line is difficult to see.

The text below it was typed as a reply.

If I right click on the aaaa in the reply I get spelling suggestions but no red squiggly line.

I have included the F7 spell check which again only picks up the above message aaaa
and misses the in message aaaa

Gopher

Spell check no longer applies to quoted text. That is intentional.

It doesn’t make any sense to check someone elses text, when all you are doing is replying to their message.

Sorry, I am not making myself clear.

I don’t want to correct the quoted email text I am answering.

For 25 years I have answered long emails with my responses inserted into gaps I have made into the quoted text (it used to be identified by <) where I have something to add.

What I have outlined above is that my new text, typed on a new line between paragraphs of quoted text is not checked. There is no wavy red line but when I right click on an obvious spelling mistake, the spell check dialogue appears with possible alternative spellings.

It is my new text I want to check.

Many people write their replies above the quoted email but this makes it hard to reply to different points throughout the email.

I accept that I seem to be part of a diminishing group who answer in this way but I thought I should point this out. It is not life or death and it seems to be done by design.

I am still a big fan of the program which helped me move on from Forte Agent. :slightly_smiling_face:

Roger

@gopher
@Gary

I can confirm that when replies are made when inserted between quoted lines, eMC does not apply the red underline.

Yes, as I said we no longer check spelling for quoted text.

So looking at the OP’s screenshot, everything below the red line I have added here is ignored.

So, just because you edit the quoted text, doesn’t mean it will be checked for spelling.

I did not edit the quoted text. The original text was in italics and the normal text was add in the reply. This was just a model to explain what I was trying to say

I wrote the new (unitalised) text to comment on the quoted text.

I often get emails with a list of (say) 5 options.

When I reply, I make a break between each option in the quoted text and type my comments on a new (unquoted) line.

I then scroll down and repeat this on the next option … and so on.

My reply is a series of quoted text passages from the original email with my new comments on each one, in between as fresh lines of text.

I find this simpler than writing my comments above the quoted email and potentially not answering everything.

eMC does not make it easy to make a clean insert into quoted text but it can be done.

Roger

1 Like

The designated border between your reply and the original quoted messages is the red line I have drawn on your screenshot.

Unfortunately it doesn’t matter how many blank lines you edit into the quoted text, it is still excluded from the spell check. If you want your reply to be checked for spelling, it needs to be above that line. Sorry.

@Gary

Guess I missed the “enhancement” in the 9.x version announcement/help.

I have no issue with not underlining misspelled words in quoted text.

However, when the reply is inserted between quoted lines, why wouldn’t there be a check for the first character of the quoted line (the bar | character) to be the determining factor to underline or not. Just a thought to be passed on to developers!

1 Like