no place to enter password for GMAIL authentication

I am trying to set up gmail. Ran the auto set up. It does not work. Checked settings , and they were incorrect. Entered proper one per gmail set up info but there is no place to enter my password for authentication. How do I do this?

Have you solve this issue? I have the same problem…

Alejandro, are you using GMail?

Hi! Yes, I use Gmail

Basically your online google account has a token to allow eM Client to access your email, calendar etc. You were prompted to allow this during the account setup in eM Client. It would have looked something like this:

At that time you would have entered your Login name and password, or if you were already logged on through a browser, you would have just clicked ALLOW. This token has your login credentials for GMail. It is not stored in the account settings in eM Client.

You can confirm this by going to

& Security tab

Apps with access to your accounts

Here you will find eM Client listed, and what it has access to on your google account.

The Token allow window doesn ́t appears…I would try again

On the same screen, you can go to Saved passwords , and here you will find you login credentials for your GMail account.

That would only have appeared the first time you setup your account in eM Client.

If you want to see it again, close eM Client.

Go to

& Security

Apps with account access > MANAGE APPS

Click on eM Client


Open eM Client.

If you have more than one GMail account, you may be prompted for the account. Then you will get:

Click on ALLOW.


I have searched for the access in my google account, but eM Client doesn ́t appears…

Does it appear on this page?

Nop…And I tried again to add my gmail account, but the allow window never appears…In the eM client my account appears, but doesn ́t work…nothing happened

should I have to open a port or something like that…?

I feel like eM Client could not open the browser

Solved!!! In my windows configuration, I didn ́t had a default browser…I chage it, and it works…Regards…

Similarly, I had my default browser set to Firefox.  I tried changing it to Internet Explorer and it worked fine after that.  

I set up (or tried to) two gmail accounts, but never saw the screen that  showed.   The first account set up fine, and began synchronizing email.    For the second account, however, I kept getting an error message that the logon credentials were incorrect, and to reenter the password.  I did this many times, but never successfully.   I tried manually setting the security protocol and port settings for IMAP and SMTP, but still no success.   I finally deleted the second account entirely, recreated it, and entered the logon information.  Everything worked, and I even saw that missing screen referred to above.  So both accounts are now synchronizing.   

I can’t say for sure why this initially failed, but wanted to report my experience.

One unexpected detail was that I needed to go to the account settings to check the box to download local copy of the mail.  Why else would I want an email client?