No Hyperlinking from email to browser

My emclient has always hyperlinked to sites from an email in emclient to the particular site, e.g. Bath and Body Works. Suddenly it won’t link.
Is this a glitch or is there a way to fix this? thanks

If you hover over the website url does the url link show (at the very bottom of the email) on the right of the subject. If you don’t see the url when you hover over the link then try other emails with links.

If you see the actual website url at the borrom of the email when you hover over the link (which you should), then it normally means (the default browser) in the OS Windows or Mac isn’t working and needs resetting or you need to just reboot your computer as might just be a glitch in the OS.

So to check your browser is set as default, if you have Windows 10 go to “Start / Settings / Apps / Default apps / Web browser” and make sure your preferred browser is set as default.

Also click “Set default by app” at the bottom and click on “your preferred browser” in the list and click “Manage” as per my eg: Microsoft Edge" browser example. Then finally make sure your browser you use is “Selected” on the right of the below options as in this Microsoft “Edge browser” example.

If you already have a default browser set ok as per below, then it might be some sort of OS glitch. In that case try closing eM Client and reboot your computer and re-open eM Client & try again.

See if this helps:

From Settings in Windows 10
->Default Apps
->Scroll down to
->Choose default applications by file type
->Change to your preferred browser

Thanks so much - I’ll give that a try.
Keep safe!

I tried again and what seems to have worked is changing the default browser (it was on Chrome) to Firefox, restarting computer and then changing default back to Chrome. It did hyperlink in Firefox so if I had to stay with that as a default, it still was a good fix. Thanks again for your help.