No data in SMTP log file

I downloaded eM Client 5/29/2014 (v6) and I cannot send email via SMTP.  I have been searching the eM knowledgebase to troubleshoot the problem but I have not found an answer.  It appears that you require the SMTP log file to troubleshoot my problem.  I turned on SMTP logging, restarted the eM client and tried to send an email.  I immediately get an error and I can see some log info if I click on the log tab in the error window.  However, the SMTP log file created is empty.  Where do I go from here?  

Hi, what mail service are you using? What version of eM client are you using?
Please don’t send us any logs prior to discussing the issue here first, thank you.

Paul. and v6.0.20320.0.  I have been trying various things to get my email to send and I have fixed my problem but the odd thing is that eM Client could have solved it for me but didn’t.

When I tried to diagnose my problem, em Client told me that SMTP failed.  I then clicked on the Fix button and em Client made a bunch of attempts to send email and eventually it was successful.  It sent a test email and told me the problem was fixed.  However, it made no changes to my SMTP settings and my emails in the outbox continued to sit there unsent.

Why does it determine what the settings should be and then not tell me what they are and why didn’t it update my SMTP settings?  The bottom line is I manually changed my SMTP settings until I found the one that worked.  BTW, it was port 587 and Force SSL/TLS.  

Hi, the diagnose/fix tool usually tries to use the most common ports for the server, but occasionally it might get a denied access from the server/port it’s trying to use, so it fails to fix the issue, that’s why there’s the option to manually change the settings.

Thank you for understanding, I’m glad the setup works now, let me know if you encounter any other issues or if you have any questions about the app,