Nextcloud attachments not converted/sent as links

Dear all,

Upgraded from 7.2 to 8.2 on two clients (no problem at all), I have tried to use attachments feature linked to my Nextcloud 21 instance.

No issue for configuring it.(User, Application Password, URL, Local folder)

Creating a short test email with an attachment located on my local replica nextcloud folder.
file is ‘uploaded’/sent to Nextcloud in a new folder so called ~ ‘eM Client Pièces jointes’ in my mother tong.
If I look on the email source, attachement is fully part of it and wasn’t replaced by a link to Nextcloud. does I made something wrong or missed some step ?
Best Regards


Using version 9.0.1708 I can add an attachment and upload it to my NextCloud. Clicking the file entry in emClient opens the download area of my cloud. → works as expected.

BUT

Opening this e-mail in my web-based email reader (browser window) there is neither a link to the file nor an attachment.

I know that this worked fine for me, seems as if it fails since last update (s. version above) but I can’t say this for sure.

Seems as if this points in the same direction as described above and seems to be solved (no more questions/no hints). Would be nice to get some solution ideas here…

Hello / Gruss Got :-),
I did the same test from my em_client (8.2.1721) and attachment is copied to the Nextcloud folder (as configured through em_client interface wit application password (Nextcloud version is the current as of today (24.0.2).
From Webmail of my ISP, attachment is there (mime attachment within the mail…no link
From mail plugin of Nextcloud, same also.
Note : On recipient side, I never got a link from the beginning of this implementation …misconfiguration from my side ?

Hope this help
Note : I saw you are using the last release of em-client which sound to me as (except if i’m wrong) a non terminated/completed implementation and avoid me to wait before upgrading to newer release.