My email address ending in googlemail.com has recently changed to gmail.com.

My email address ending in googlemail.com has recently changed to gmail.com. I don’t know whether this happened on an update, or what, but it is causing me problems with my utilities provider, who say that they don’t recognize my address. Is it eM Client who has done this, or Google, and what shall I do?

I know that when you login to Gmail web interface with a googlemail.com address it asks if you want to change the address. That could be how it was done. You can still send from the gogglemail.com address in eM Client, but I think the receiver will see it as from gmail.com, but I could be wrong.

You can check what is in eM Client by going to Menu > Tools > Accounts.

Your best bet will be to update your utility provider with your new address. Sometimes they just don’t understand much about email addresses probably because their system sees them as different and they cannot think for themselves. But me.home@gmail.com, me.home@googlemail.com, mehome@gmail.com and me.home+utilities@gmail.com are all the same address.

Thanks for your prompt reply.

Something is definitely going on with eM Client, which is the only place where the change has taken place. Things remain as they were in Google/gmail itself.  And I did nothing to effect the change myself.

You kindly referred me to Menu/Tools/Accounts.  In there, I have changed the address back again to  [name]@googlemail.com.  The account name is now correct, and it has remained correct when I have logged out and logged back in again.  BUT when I send an email from it, eM Client takes it upon itself to change the address back again to [name]@gmail.com.  Masses of people have my googlemail address and I really don’t want to go through the same rigmarole with other people as I am going through with my utility provider, even if it is mere ignorance which causes them to dispute the new address.

I would be most grateful for your further help

When your Google account is changed from googlemail to gmail, all email you send will be from gmail.com irrespective of your settings in eM Client. It is not really a big problem because all email sent to the googlemail address will be received in the gmail one.

You can change it back in the web interface for your Gmail account. Open the account settings (cog icon in the top right somewhere) and go to the Accounts and Import tab. Next to your email address in Send mail as: there is a link to switch back to googlemail.

Hope that solves all your problems.

You miss my point. My Google account has not been changed at all , the only change is in eM Client.  On my phone, I do not even have eM Client and send my emails directly through Google. emails which I send from my [name]@googlemail.com show that address.  It’s only when I use eM Client that the problem arises. It must therefore be eM Client causing that problem.

It does not really matter what email address you put in eM Client. Gmail will change that to what is in Send mail as setting.

Please check your Gmail settings through the web interface.

Saying that I just tested it. Sending to a mail.com address I always get the setting in Gmail. Sending to a Gmail address, I get the eM Client setting. Sorry.

There are two places in eM Client where the email address is. Are they both googlemail.com addresses?

The User Information one is the address that becomes the From: address.

If they appear correct, please send me an email from the account to gary.curtin@gmail.com

Bingo.  One address was still wrong.  I think and hope the problem is now fixed.  Thanks for sticking with me!  Beats me how all this happened, since I’ve never been into settings since the day I installed the software.