Move to folder in a rule not the same result as moving manually

When creating a rule that moves a message to a folder, the result is not the same as if you manually click on the message and move it to a folder.

For example, if you create a rule based on the incoming message email address, that moves the from the Inbox to a sub-folder under the Inbox (say one named Github), marks it as read, and disables the notification, when a  message comes in that matched the rule it is moved to the folder, but it also remains in the Inbox.

If you take the same message with no rules enabled and click on it and choose move and move it to another folder it no longer remains in the Inbox.  I believe this is because the message still has the “Inbox” category assigned to it when the rule attempts to move it, but the Inbox category is removed on a manual move.

This started occurring when I upgraded from eM Client 6 to 7.  This same rule worked under 6.

eM Client 7.0.27920.0
Windows 7 Home Premium
Gmail using IMAP setup with the automatic setup

Thanks in advance!


Did you make sure your rule isn’t ‘copy to folder’?

Yup, it’s a move.

Yes I know it worked in v. 6 because I had a rule set to move emails from inbox to a specific folder and never had the issue you describe.  However I no longer use the rule so I cannot verify.

Hello Joe,
unfortunately with the improved support of the Gmail labels the rule cannot remove the Inbox label so instead of the message’s label being changed it is just added.
Sorry for the inconvenience.


Thank you for the prompt response Olivia.  I’ll put some thought around how to work around that.

Hello Joe,
thank you for understanding, we are trying to figure out a possible workaround on our side as well.


Any progress on this?  I just recently upgraded from 6 to 7 and like the changes, but this problem is a killer.  I don’t have time to manually move 3 or 4 thousand emails every day.


Bill, I have a work around that you might try, and is working for me.

The gist of it is you create a “dummy” account (even the free version of eM allows 2 accounts) that you don’t actually use to send or receive email, and that is where you move the message to in the rule.

Go to Accounts, and create a new Mail account, choose Other as the type.  Just make up an email address, and then for the incoming server make up a non-existent domain, put in anything for the user name.  When you come to the test page, just check the “Ignore test results” checkbox.  Make sure you choose “Create separate folder tree for messages”.  Cancel all the prompts for passwords, and go to the Account screen for the new account and uncheck "Include when sending / receiving emails (this will keep you from getting prompted for a password).

Essentially, at this point, you’ve just created a folder structure that is not really attached to an email account.

Then, in your rule, move the message to one of the folders in this dummy account.  Apparently because it’s in a different account, it actually removes them from the real account’s Inbox when processing the rule.

I hope this helps.

Any fix for this? Please?
As much as I appreciate Joe’s workaround, I feel strongly that it shouldn’t be necessary to create a dummy email account.

How about adding an “Archive email” action for accounts that use Gmail?
That’s essentially what I do in Gmail’s web client. Apply a label and archive it, and it still shows up in the label/folder.

My suggestion is to create the rule in the Gmail environment (i.e., web client) rather than eM Client.  It will then work on any client without having to set up the rule again.

Excellent! Thank you, Jay, that worked perfectly :slight_smile: