Missing messages older than one week old

Hey all, I am having an issue with my IMAP account whereby messages older than a week are going missing, almost like its archiving them. I cannot seem to find where this can be changed to stop it happening. The emails have never been backed up so far and I have stretched out the auto archive frequency to over 200 days, yet it is still happening. Sorry if this is a bit vague, I am not currently able to access my computer as I am out of town. Any help would be greatly appreciated. Cheers.

Hi, are you sure you’re using an IMAP account, this sounds a bit similar to wrong server settings of a POP3 account?
Can you try disabling the automatic archiving completely?

If the emails were archived you should be seeing all the mail in your local folders…

Thank you, Paul.

Hi Paul,

It is definitely IMAP, recently set up with em client due to Outlook being unable to play nicely with IMAP. We have two computers accessing the one account and everything syncs fine across them. This is a business email account linked to our web page provider (hope that makes sense). I have turned off auto archiving completely and to make sure I put it out to 200 days just in case. When we had it set up as POP3 there were no issues, but that was with Outlook.

Ok, can you please also go to Tools > Settings > Advanced and turn on IMAP logging for the problematic account? Right click the email account and select Properties > Repair and click on the Repair button.
If that doesn’t solve the issue, wait until the issue occurs again, and if it does go back to the Advanced settings window and click on send logs, please send it to my email (mcgregor@emclient.com), and please add a reference link to this forum topic.

Thank you,
Paul.

Thank you Paul. I will try to organise this within the next 24 hours.

Hi Paul,

Have sent you an email.

Hi, I’ve received the logs but have a followup question, are the messages available in your webmail (on your server), can you try logging into your webmail and check this?

Thank you,
Paul.

Hi Paul,

My wife isn’t sure how to log on directly, but will find out. The issue she is having is that she is receiving error messages saying her mailbox is full and cannot receive any more emails. This is strange considering she cannot access any emails older than a week old. Here is the message:

Subject: Mail delivery failed: returning message to sender

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

mailbox is full: retry timeout exceeded

Hi, the issue here is that the mailbox of the recipient is full, means the person you’re sending the message to needs to clean his mailbox (unless that’s a message you get if you try to send an email to your wife). If so, you need to archive old emails or delete them to clean the mailbox.

Hope this helps.

Also you should be able to login to your account by going to the website of your mail service for example gmail.com if your email is setup with gmail. And use your login information to access the mail.

Thank you,
Paul.

It is her mailbox that is full apparently. That was a test message she tried to send to herself. She is trying to get in touch with her web design person to find out the web address to login directly to her account.

Is this an issue because IMAP doesn’t store email locally and keeps it on the server?

It might be, if you’re using IMAP all your data is stored on the server and you’re in control of that data through your mail client as well so if you delete emails in eM Client, they should be deleted on the server as well (don’t forget to empty the trash folder).

Or another cause for this issue might be the fact that the mailbox is setup for a really small storage, that you simply ran out of space, you can adjust this if you’re using a private domain mail in the webhosting/mailhosting settings.

Paul.

Ok, my wife will try to get that resolved. Then we will see if the original issue still exists. It seems as though there is still only exactly one weeks worth of emails in her inbox. If she logs in via POP3 in Outlook she can access all of the older emails.

Ok, please keep me posted. If you’re able to view the previous emails in Outlook, is it possible you have your messages stored in local folders? POP protocol only downloads new email…

Thank you,
Paul.

Looks like we need more space. We are getting someone to look into it for us now. Sorry for that little distraction. The original issue still exists whereby only one weeks worth of emails are being kept. I now have access to em client now that I am home and cannot find anything in any settings that may trigger this to happen. Should we continue to search for the issue or maybe try to reinstall em?

I see your point about using Outlook alongside em too, sounds feasible although it is always exactly 7 days worth of emails that is kept in the inbox.

Hi, if you have now more space on your server, it’s important to check the settings of your POP3 account under outlook - there’s a setting for POP3 accounts that deletes emails from the server after X days or even after they are downloaded.

So please make sure your Outlook settings are not causing this, if you’re using IMAP on eM client there’s not really anything that could be causing this.

Thank you,
Paul.

Yes that makes sense. I’ll have a look now.

Checked the pop3 settings and you are spot on - was set to delete from server after 7 days. You have done a great job working through this. My wife and I are very thankful for your assistance. I will report back in a few days to confirm it worked.

Thanks once again

Great, make sure to let me know, I hope it works though.
If you come across any other issues, or have any questions about eM client, let us know, we’ll be happy to help.

Thank you,
Paul.

Hi Paul,

All is working great. Receiving emails and they are not being deleted. Have activated the two licences and seems to be running smoothly. Thanks once again, you have gone above and beyond.

Cheers.