Missing extensions for attachments


I can not send an attachment with my mails. When i go into settings there are no extensions in the list and i don’t know how to add them. I am sure that i clicked on all of them when i was setting up my account because i need to send a lot of attachments. How can this be fixed, please???

I am not having any trouble attaching ANY files to outbound email, clicking on the attachment icon on the editor heading line. Do you not see the icon?

I just looked at the settings you mentioned (did not even know it was there :grinning:) and noted that I had only 1 entry for ‘jpg’ and that it states the setting is for “Default actions for attachments”. Not even sure what that means…

Bottom line

hello Sunriseal,
Yes, i do see the icon and i can select the attachment in my files but then when i want to send the email i get a seperate error for each attached file or picture… and it says something like that it doesn’t recognize the extension of the files. I think it is because there are no extension in that list (like where you have the jpg), but i am not sure. i’m not an expert, otherwise i could fix it without asking for help :smile: and i don’t find how to add any extension to that list. Hope someone can help me because it is really necessary that i can send attachments with my mails. I use it not just for private things but also for business…

Hello Maika,

you drag and drop the photos into the e-mail (red arrow)
or do you add it as an attachment (yellow arrow)?

Do you have a screenshot of the error message?

yellow red

I tested it again on my end and I was able to send a TXT file attachment (test.txt) and it went without an issue…

I wish I had a resolution.


I already tried both ways, doesn’t work… and since today i get the same error about my signature ( which includes a logo)… :cry:
yes, i have a screenshot:

Don’t know if you understand dutch but it says can not include attachement, document and location of document and then could not be added as an attachement because of following error: object reference not set to an instance of an object
any idea what the problem is?

Hallo Maika,

Greetings from Germany to the Netherlands? !

Oh, ha. I think I’m out of my depth.

I tried to recreate it with the path. Deviation D:… No problem.

Does it generally not work, even with another .jpg / .jpeg file (or .txt, .doc,…) from a different path (c:\test) ? If that’s the case - I’m afraid I’m out of that now :unamused:.

I have the same issue. No matter how I want to add an attachment, no matter which file type I get “object reference not set to an instance of an object”. It is unusable without the possibility to add attachments

It may help to download the current program version again.

  • Briefly terminate the real-time protection of the antivirus program.
  • Install the current version eM Client (again).

Windows current Version today:
Version 7: 7.2.40748.0
Version 8: 8.0.2951.0

It didnt help, I am reverting to version 7 until it will get resolved