Missing Attachments (.P7m) with attachment.txt file instead

I’m testing this email client for some of my clients here in Europe. I noticed that somehow when I receive some attachments (.P7m, is a Digitally signed file) I am unable to see them while I correctly receive If I check my web mail. Somehow the client blocks them on all mails and I cannot find any way to add the .p7m extension to the thrusted extensions (Assuming this is a security problem) 

This sounds related.  Try this:  http://support.microsoft.com/kb/913966

From the start.
1 - I’m using em client.
2 - other people use what they wants

When other people send (from any mail and from any software) emails to me, and to another person, The other person receive the mail correctly and see all attachments correctly (No matter what extension they have). I, on the other side, can see the attachments correctly only accessing my web mail. If I access my mail accounts (I use 3 and I am talking of all the 3 mail types, IMAP, MAPI and POP) whit EM Client, for some reason i see other attachments and I see a attachment.txt instead of every *.p7m file. This cannot be related to a Microsoft Knowledge rtelated to “users in a Microsoft Exchange Server 2003” environment. 

Hi Ema, what version of eM Client are you currently using on your computer, can you check for the exact version number in Help > About? What mail service are you using with eM client? Can you please make a screenshot of the issue?

Are you seeing any errors from the application?

Thank you,

Version 6.0.21040.0 Just donwloaded a week ago

Sorry.  I misread the Microsoft post.  I thought it was describing a setting in Windows registry that wasn’t handling the p7m file properly.

I think I’ve seen what you describe before when there is an email server spam or virus filter that intercepts the email and removes/changes the attachment.  But, if the other person is getting the attachment, that may not be the case.  Is the other person in the same domain as you - with a different email address after the “@” sign?  If they are different, it could be that your email server has the filter but the other person’s email server does not or is configured differently.

By the way, just to be clear, I’m another user just trying to be helpful :slight_smile:

Mail services are gmail, outlook and tiscali (Last one is Italian) But Since it’s 3 mail services I doubt it’s depending on them. Either this issue is related to the client or to my p

Anyway A mail is coming so I can take a screenshot of the mail

:slight_smile: Yes, I understand that. Antivirus is Avira+Malwarebytes and the user who’s helping me find the problem is using these same softwares and he seems to not have this problem. No email protection inserted.

I also have made a new test. I tried sending a simple pdf file renamed p7m, a pdf file and a doc file attached to an email and I sent this email to myself. This is what I got on my 3 emails

I’m trying to get a correct p7m file so I can send it . In the mails I received from my collegue there was the attachment.txt file empty and no error file…

Ok. When they send me the file p7m, this is what I get

If you view the Mail Header, does it say anything odd?  Right click on the message in the message list to the option.  Check the Mail source as well.  Compare to the ones that worked for your friend.

How am I supposed to compare differences between 2 different software and between a sender and a mailer, Vincent? Also, Where should be the propriety window in EM Client?

I believe this is a waste of time. Anyway, this is the header of the last mail received

x-store-info:sbevkl2QZR7OXo7WID5ZcdV2tiiWGqTn2fmeaihh4TwPC29H8VQKDQ9Dz2JxnbExGID5cN8HKhYkN55XEKrc02MVpToOtadvxh+am/+AfypAIVAuTliVlLavdO2nZ4Pl1Qy70byyyUs=Authentication-Results: hotmail.com; spf=softfail (sender IP is
; dkim=none header.d=tiscali.it; x-hmca=fail

X-SID-Result: FAIL
X-Message-Status: n:n
X-Message-Delivery: Vj0xLjE7dXM9MDtsPTA7YT0xO0Q9MTtHRD0xO1NDTD0w
X-Message-Info: NhFq/7gR1vQRHV6jbdvQfsKUeeVAoUVojAJS6DKEC2GNUUM0G+IdixjOQJpUt4rNQ8UbTr3sNSXJ7/olz5W9nPpN5qJiQqXYmCWDYNoVfuL/BgGGaoI4aR2QyJasGlhR2hY8dg0XS+66fxCpQ7M1YF4WXBUM1iCQWvmocKYRsJrEvcGuAStds+Qka7cMTxs31vw6TAchmPD/tTu4e28kBnEzSF1NR9nA
Received: from smtp-32.italiaonline.it ([]) by SNT004-MC2F20.hotmail.com with Microsoft SMTPSVC(7.5.7601.22751);
Wed, 3 Dec 2014 09:56:22 -0800
Received: from Tirdog2PC ([])
by smtp-32.iol.local with bizsmtp
id P5w81p00K3Vvztz0Y5w8ym; Wed, 03 Dec 2014 18:56:21 +0100
x-libjamoibt: 1601
X-CNFS-Analysis: v=2.1 cv=Kb5csGoD c=1 sm=1 tr=0
 a=JkCGFl0goP4cB4G6j26uHA==:117 a=JkCGFl0goP4cB4G6j26uHA==:17
 a=r77TgQKjGQsHNAKrUKIA:9 a=9iDbn-4jx3cA:10 a=cKsnjEOsciEA:10
 a=gZbpxnkM3yUA:10 a=X_zeENMNKJ_dJXm-5TwA:9 a=wPNLvfGTeEIA:10
 a=ippV2s9GacQA:10 a=C8qMI9ugCawA:10 a=wD6l2a1g_Q8A:10
 a=JY-qkmCQ1JXHz0JBpUkA:9 a=69bG887SKLrUyGHju6QA:9 a=n3BslyFRqc0A:10

Subject: I: Invio per posta elettronica: figini varzi pv.PDF.p7m
Date: Wed, 3 Dec 2014 18:56:03 +0100
Message-ID: <001201d00f22$6785a1a0$3690e4e0$@it>
MIME-Version: 1.0
Content-Type: multipart/mixed;
X-Mailer: Microsoft Office Outlook 12.0
Thread-Index: AdAPBFiD1cZU3Df2QlCSWJI88hufPAAHdY/Q
Content-Language: it
X-OriginalArrivalTime: 03 Dec 2014 17:56:22.0131 (UTC) FILETIME=[72B1E430:01D00F22]

Hi, sorry for my late reply regarding this issue.
When receiving this message, are you seeing an “encryption has problems” error on top of the message?

This would point out that you’re missing a certificate to decode this s/mime message.

Thank you,

Got the same issue, these p7m files i need are not something that eM Client even should attempt to open. How can i stop eM from trying to read them?

Hello, I’m not quite sure what you’re suggesting. p7m files contain an encrypted message, if you don’t have a valid certificate to decrypt the encrypted message you won’t be able to view it. eM Client is an email client that is used for displaying messages (quite often), I believe opening the encrypted message is exactly what the client is supposed to do, but can’t achieve it without a proper public key or private key if needed.


Its not an email message its an encrypted file containing data that can only be read by another application. An option to not touch the attachments in a mail should be implemented in eM.

I’m not really sure what you’re suggesting, is eM Client displaying the message? If it’s an attachment of the message eM Client is the application receiving the message, note that the application is offline, and that none of your data are being shared with another person or application nor server. If this is an encrypted file, that eM Client can display without the necessary decryption key, I’d consider this an issue, but I’m really not sure what kind of issues you’re having. Can you please describe the problem or specify the behaviour?

Or make a screenshot of the issue?

Thank you,

22-10-2015: the problem is still unresolved:

file with extension .p7m are not displayed by the em-client in their place appears a file of 0 Bite called “attachment unnamed”

with other clients not happen.
on the mail server is okay!
if you compress the files okay!
if you export the email from em-client and reopen with another client the Annex is there!

file .p7m is a digitally signed PDF file: in my case with the program “ArubaSign” Aruba (www.pec.it)

I have the same issue with .P7M files. Both with Google apps or Exchang 36. Found any workaround?