Messages not being marked as read after being opened

When I open messages with a double click to read them in a new window, they do not get marked as read in the message list. I know people have had this or a similar issue with past versions, but I am using the latest version 3.0.10206.0.

I have unchecked the option to mark as read after x seconds displayed in the preview pane, but do have the preview pane activated under the message list.

This is happening in my IMAP Inbox folder for my Google Apps account. The messages stay marked as unread in the webmail interface as long as they remain marked as such in eM Client. Messages read in webmail (and consequently marked as such) are not immediately marked as read in eM client, but are marked as read upon restarting eM Client.

Yes, message isn’t marked as read if you have unchecked this option in Tools->Settings->Read. Message is marked as read only with this option checked and after amount of seconds set. If you want messages to be marked immediately check this option and set numbers of seconds to 0.

We analyze the bug you described in the last paragraph and we will try to fix it as soon as possible.

So messages are not marked immediately as read in eM Client after they are read in gmail because of the gmail. Unfortunately gmail doesn’t send notification about reading so we can’t do anything about that.

Let me try to be a little more clear about the issue I’m having.

I double click a new message in any folder. It opens. I read it. I close it. But it remains marked as unread in the message list.

I would prefer if there were some way I could set things so that new messages are marked as read as soon as they are double clicked (but NOT after any amount of time being displayed in the preview pane). This happens if I check the option to mark as read after 0 seconds and disable the preview pane. But I don’t want to disable the preview pane.

I’m working in Windows 7, if it matters.


the behavior you are asking for cannot be achieved in current version. However we will add this feature to the feature list and it is very likely to appear in one of the future updates.

Petr Zadražil


There must be a workaround for this…Thunderbird can mark as read. Maybe check read status on server manually?

Zimbra can also mark as read. Kinda defeats the purpose of imap.

this is already implemented and should work without any problems.

It doesnt work for me. What can I try?

Check your settings: open Tools - Settings - Read to see if the option “Mark message read after opening in separate window” is checked.

I am confused. Are we talking about the same problem. I want to be able to read my email on an imap client other than emclient and for it to show up in emclient as read.


Just for clarification - you open a message e.g. in webmail, read it and this message remains marked as unread in eM Client? What happens when you click Send and Receive button?

correct - after hitting send/receive, there is no change as it is still marked as unread

My wife has the same problem and uses a different webmail client.

Send us your logs please: go to menu Tools->Settings->Logging and check “IMAP”. Then restart eM Client, try to simulate the issue and send us (with reference to this topic) the logs using the same logging settings window. Thank you.

IMAP logging is already checked, but I just realized something…If I close emclient and reopen, it shows marked as read. Do you still want me to send?

In that case the problem lies on the server side. Full synchronization is needed to change status of messages. You do not have to send us your logs, because I cannot provide you any other solution.

So the problem lies with gmail? Why can’t a full synchronization be done?

Oh, you are using Gmail? We have not experienced this issue with Gmail IMAP servers, it is really strange. Send us the log so we can check it. Thank you.

I sent the logs using send logs function and it said “this will take a long time” - it has seemed to send, but I don’t see it in “sent” folder