Messages marking as read.

Messages marked as read when I do not want them to be,whether I have read them or not. Changing mail settings makes no difference.

Hello Bob,
what account does this happen on? Do you check it from other devices?
Do you have any rules set up that could be causing this?

Regards,
Olivia

Hi Olivia,
Not quite sure what you mean by “account”. Not checked on any other device. Following the demise of my desktop I have one laptop and that’s it. I have not set any rules. Having tried everything else I could think of I have marked everything as unread on the server. At the moment they seem to be staying unread in eM Client. This may have cracked it but unread/read has been a bit come and go lately. I have two email accounts. The secondary one has behaved at all times but not the other. I have just checked again and they are staying unread. Could this be it? Perhaps I could let you know?
Regards,
Bob.
Thank you for your interest.

Hello again Olivia,
It’s working for those that are marked as read on the server but newer messages are marking themselves as read again.
Bob

Hello Bob,
by accounts I mean your mail addresses, depending on how many you have.
What type of account is the one that is misbehaving? Is it a gmail/outlook/yahoo/other type of account? Is it set up as IMAP/Exchange/POP?

Regards,
Olivia

Hi Olivia,I’ll try to get this right. Two accounts/email addresses. It’s this one, the Talktalk. IMAP. The other is BTinternet POP. No problem with this one (BT).
Bob.

Hello Bob,
unfortunately we’ll need to see more detailed IMAP logs to see why this issue happens.

Go to Tools>Settings>Advanced.
Check IMAP logs for your Talktalk account.
Restart eM Client.
When this issue happens again, go to Advanced settings, click Send logs, change the recipient to rust@emclient.com with a link to this forum topic in the body of the message,

Regards,
Olivia

Hello Bob,
I checked the logs and there seemed to be only one new message that synced as unread and few hours later got marked as read (which I’d assume would be you opening it or reading it), but the message has been synced correctly and shows as unread in the logs.
What is your setting for marking messages as read in the Tools>Settings>Mail>Read section? How many seconds does a message need to be opened? Does the same issue happen if you disable the automatic marking as Read after reading the message?

What version of eM Client are you running? Check the Help>About section.

Regards,
Olivia

Hi Olivia,I did reply but not heard back. Did I do something wrongly? Anyway,I have tried all and any combinations of off/on settings regarding read times etc. to no avail.
Bob.

To anyone that comes across this issue, I believe I have found the problem and a work-around for it. Details are posted at:
https://forum.emclient.com/emclient/topics/problem_with_messages_marked_as_read?topic-reply-list%5Bs…

Hopefully eM Client will fix the issue now that it’s clear why it’s happening.