Messages encrypted for all recipients even if you don't have certs for all of them - prompt for sending unecrypted to those is ignored

In that example I sent a mesage to 3 recipients (bcc:)
I manually checked to encrypt the message (= lock icon in compose window).
But I only had the cert of 1 recipient.
When I clicked SEND, I got 1 prompt for each recipient - for that I did not have a cert - if I want to send unencrypted to that recipient instead (so in total I got 2 prompts).
I said “yes” (= send unencrypted), but surprislingly the message was nevertheless encrypted (but to whose recipient’s cert? I don’t have them all.)
I checked this on the web interface of gmail:
In fact there is 1 common message to ALL recipients AND it is encrypted (so 2 of 3 people will not be able to read it):    --> see “smime.p7m” in that message as proof of encryption:

Surprisingly eM Client only says that the message was SIGNED, but NOT encrypted:

I also tested the same by using “Send as MASS MAIL”.
That way, the e-mail is split into single mails (1 message per recipient).
But same problem: although i was asked if I want to send unencrypted to 2 of my 3 recipients, ALL 3 separate messages were encrypted.

Hi, as I mentioned in another topic with this issue, a window confirming if you want to send the email unencrypted should appear, I was able to replicate this issue and I’ve reported it to the developers.
But I’m currently waiting for a response, I’ll let you know once I have more information on why is this occurring.

Thank you for understanding,

Well, in fact in that case here, the window/question (if I want to send unencrypted instead) comes up, but is ignored. 
My settings here:  Tools > Settings > Mail > Certificates > Security profiles > Require encryption: NO.
I create a message to 3 people. I have only the cert of 1 of them.
I manually activate encryption by clicking on the lock icon in compose window.
Result: Mail is encrypted to all 3 recipients (window/question/answer “send unecrypted” is ignored).

The other case was:
Tools > Settings > Mail > Certificates > Security profiles > Require encryption: YES.
If I send a message to a person whose cert i don’t have, the window/prompt says, I cannot send at all. No choice to send unecrypted instead.

Hi again, just mentioned this under another forum topic with this issue, I’ve notified the developers and this is unfortunately intended behavior, however we’re considering improving this for future releases, but in the meantime you have to uncheck the encryption of an email manually.

Thank you for understanding and sorry for the inconvenience,