Message displays in HTML Source, for non-English

I have never had this problem with Outlook.
GMail is my server.

I correspond in English, Chinese, Arabic and Hebrew.

All English messages are displayed normally.

For non-English emails, the title is shown by weird symbols.

The message body is displayed as HTML source, with the actual foreign letters embedded inside a mass of HTML code.

I tried the Format-Plain Text. Did nothing.
Also tried Settings-Message-Read - Plain Text. Did nothing.

I like this client - most user-friendly which I’ve tried so far, but this problem is a deal-breaker.
Any help?


M Yachad

1 Like