Main Window Suddenly Invisible

Note: this is a display issue (lack thereof) with no crashing.

I’ve been using eM Client Pro for a little over a year now with no issues, until today. All eM Client windows can be opened (and used successfully, including sending email) from the Taskbar, except the main window (Inbox) - see Taskbar screen snip below.

The app is running in Task Manager (Windows 11) but the only way to see what the main screen looks like (if it had been displayed), is by hovering the cursor over the activated icon on the taskbar (see screen snip below).


I’ve run the command line DB repair and it shows green checkboxes. Several reboots didn’t remedy the issue either. Short of un-installing/re-installing the app (I would need pro license de-activation on this machine in order to install on another - not going to take a chance on this machine with the app, although this sort of problem has never occurred with any other of my apps). Re-installation would also require access to the numerous stored filters in the existing DB (if that’s not in human-readable format, it would be a show stopper for me, unless rules can be imported).

I have 5 email accounts and am really hoping that there are other things I could try. If anyone has has a suggestion for a possible solution it would be greatly appreciated. Thanks in advance.

Try right clicking on the eM Client taskbar icon and then with your keyboard key, “press your up arrow” till you are on eM Client “at the bottom of the menu”, and then “Hit enter” and see if the main GUI opens.

If it then opens ok, close and reopen eM Client.

Thank you for the suggestion @ cyberzork but unfortunately that didn’t do the trick. I followed your instructions exactly as you stated, several times.

I wonder if the main window is maybe off screen or on another desktop. Hover your mouse over the taskbar icon and then right-click in the preview and choose MOVE. Use your keyboard arrow keys to bring it back onto your screen. Once you see it, you can use your mouse to drag it to where you want it.

1 Like

@Gary, move is greyed out, but thank you for that suggestion. It turns out that it’s a Windows 11 issue. The same thing happened on the browser today. I rolled back the Windows 11 update that came yesterday and restarted. The monitor is completely black now (cycled power twice) but I noticed that the file system is still accessible from 2 other computers, so it is on, but not displaying anything. So i tried remote control with NoMachine (worked) and logged in the black monitor machine, started eM Client and the main window came up right away (same with the browser). It’s usable like this, but Windows 11 not playing nice on that machine, so may eventually go to Linux or Windows 10.

Now I’m setup to do a eM Client full backup for when I may install on Windows 10 later. So I have a couple of questions…

  1. Does a full backup include the filter rules ?
  2. How would I manage re-installing the license on a different OS or machine (I have the key) ?

I thank both of you for your good suggestions for my problem !