mail not sending

Mail simply sits in the Outbox. No indication the send is doing anything.

what version of eM Client are you using? What email provider are you using?
Is this a new issue, was it working before properly?
Have you noticed any errors while trying to send your email?

Thank you,

Hi Paul!

version is 6.0.19861.0 popped to First time installing it (using Outlook 2003 before). Mail still doesn’t send. I’ll try reinstalling it later today.


Hi, Can you please post a screenshot of your SMTP tab under your account in Tools > Accounts?

Thank you,

could you try setting the port to 587 and use “Force usage of of SSL/TLS” and let me know if it solves the issue?

Thank you,

Paul, this is Nancy with the same problem as Bill. I tried changing the SMTP port to 587 and used the :force usage of SSL/TLS but still couldn’t send.

can you please go to Tools > Settings > Advanced and turn on SMTP logging for the problematic account, save the settins and restart the application.
If the email still sits in the outbox, please try clicking the “Send and Receive” button and if it still won’t send go to the Advanced settings window and click on “Send Logs”,
please add my email as a copy to the mail with the logs (

Thank you,

This is Sheila with the same problem. I will send you a copy of my SMTP log. One thing to know: I’m using Google 2 step verification on my account and I’m wondering if this has some impact on the problem.
BTW: it would be great if emclient had some support for setting up an account with 2 step verification. I had to do some searching online and found info on doing this with Outlook which I applied to the setup. I’m sure I’m not the only one with this issue.

Can’t send log from emclient because it can’t connect through gmail. Very frustrating. Will try to copy and send through web.

Hi, if you’re using Gmail’s two step verification make sure you’re using the right password to your email. With this feature activated you have to generate an app specific password which you then use instead of your regular password that you would regularly use when logging into your webmail.

You should be able to find the password generating site somewhere on this page ( Also note that you now have to change the password both in your IMAP and SMTP settings in Tools > Accounts > Your Account > IMAP / SMTP.

Thank you,


I used my 2 step PW on the SMTP setting – still no mail going out.
I tried resetting with my regular gmail PW – no outgoing mail.
Nothing seems to work. Will try one more time deleting the account and setting up again and see if it works, but otherwise have to give up on the product.

Try to setup the account again with the generated password, let me know if it worked.

But if it doesn’t can you please go to Tools > Settings > Advanced and turn on SMTP logging for the problematic account, then save the settings and restart the application, try to send out an email and if it doesn’t send, go back to the advanced settings window and click on Send Logs, please add my email ( as a copy to the email with the logs and add a reference link to the body of the message.

Thank you,

I too have this problem… and have always had this problem

I THINK it may be related to the Sync that’s happening.  I am using Hotmail/Outlook and have a LOT of folders. Every sync goes through all of the folders and it takes a long time.  My guess is that the checking of the folders is causing a delay but I am not sure. 

This is THE problem that is stopping me from moving over completely from Windows Live Mail.  You fixed one critical bug in setting the “To” field correctly when message is placed in the Sent folder.  Now all is well in terms of the overall functionality.

If this send problem was fixed, I would  gladly pay for the program. It rocks!

PLEASE PLEASE help with this send problem.


Hi Mike, what version of eM client are you currently using, are you seeing any errors from the application?
Are you using a firewall/proxy/antivirus software on your computer?

Thank you,

Hey Paul

The version I am using is 6.0.20617.0
I get no errors at all. It looks good with the overall functionality, etc.  The only issue is the message sitting in the outbox.

I did find that if I exit, the message continues to sit there.  However, upon starting the program again, it send i immediately.

The firewall I use is the Windows 7 one, standard issue.  My AntiVirus is Avast.  

It really does seem like the delay is due to the folder sync / check incoming mail.

If there is no checking of my folders for new emails, then I see in the status line at the bottom “sending message” and it goes out right away.  However, when the folder check is happening, the message is delayed.  If the checking of incoming mail / folders was quicker, then I don’t believe there would be much of an issue.  I can deal with a 1 minute wait time, but this is a significant amount of time.  

When I say I have a lot of folders, it’s not extreme.  Maybe 50.  Just looking at the log that is shown in the “Operations” box, it appears that it takes 10 minutes or more to check for new messages.

Looking thought the log, it takes 2 seconds per folder.  Not bad. But it’s checking them multiple times in the same runthrough of the message check cycle.  I can email you that log if you would like. 

So, debugging with what I have seen in the logs and tested, it looks like the check for message cycle is going through things many times and thus taking much longer than it should.  While the check is happening, outgoing messages are sitting in queue waiting for the check to finish.

I want to thank you for answering my post SO QUICKLY, especially since you’re an employee and I am using free software.  Excellent service on the part of your company. It’s impressive.

Thank you

Hi Mike,
can you please go to Tools > Settings > General, and check the synchronization period setup in eM Client? (“Synchronize items every X minutes”), what value is it setup to?

You can also try to update to this version of eM Client and check if the issue still persists.

Thank you and sorry for the inconvenience,

Hiya Paul
No need for an appology, at all. You’re all over this and that’s more than what I excepted so we’re good.

My Sync time I set to 10 minutes.  I think the initial value was 15 minutes, but I didn’t want to wait THAT long to get my email.  Let me know if I should change it and what effect it has to receiving new email.

I have downloaded the .MSI and will be giving it a try today.

I again really appreciate the help from you service folks.  Someone there is running a good department.

I’ll let ya know about the new version’s results.


Hi again Mike,
can you please go to Tools > Settings > Advanced and turn on IMAP logging for the problematic account?

  1. Save the settings
  2. Restart the application
  3. Replicate the issue
    When you notice this problem occurs again, go back to the advanced settings window and click on “Send logs” and send the logs to with a reference link to this forum topic.

Thank you,