Mail bypasses inbox and ends up in "All Mail"

Mail bypasses inbox and ends up in “All Mail”. It’s OK if it is in both the inbox and All mail. I want it in the inbox unless I move it using a rule.

If this is a Gmail account check if this is also happening online in your Gmail account.

If it is happening online, then check your Gmail filters and rules online, as it would then be a mailbox server settings related issue.

Now if it’s ok online and new emails are showing ok in your Inbox label, then go to “Menu / Rules” in eM Client and see if you have accidentally setup some sort of Inbox rule doing this. When you get into rules, at the top in the dropdown you can select between Local & Server acct rules.