Local folders lost

Local folders lost. Yesterday I installed eM Client 7. All folders are imported, the local folders too. Todax the Local folders aren ́t visible. I say “local folders” at the left side but this folder is empty. What can i do ? Can I go back to Version 6 ?

Hello Peter,
are the Local folders set to show in Menu>Tools>Settings>General>General section?
eM Client cannot just randomly remove your locally saved messages. Could you screenshot the Folder list?

You can, of course, go back to eM Client 6 if you need - the installation file is on our download site and in release history.
Just uninstall eM Client 7 first.


Thank you, Olivia. Meanwhile the problem is solved, but don ́t ask me why. I did several restarts, there was an windows update in between. But now everything works how it should. Thank you for your answer.

Hello Peter,
thank you for letting me know, I’m glad to hear the issue is resolved.


We’ve had the same problem but no resolve. A month ago my dad updated his eM client as prompted, loosing the content of his local files. Years of data that was removed from the server by eM client seems to be lost forever. The folders are set to show in   Menu>Tools>Settings>General>General. I’d like to set it back to how it was, but I don’t see how uninstalling and reinstalling an older version of the app would bring back his files. Can you suggest anything?

Looks like the option to import version 6 data during the upgrade was skipped. This can still be done by going to menu/file/import and select eM Client 6. The upgrade does not delete any data, just copies and converts it to the new v. 7 format. Version 6 data remains. As I remember, however, after a period of time, eM Clients asks if you wish to delete old files (after 30 days?). Hopefully, that option was not selected.

I copied a folder test 1 from an IMAP account to my local Inbox as a sub-folder. Worked OK.

Then tried to create another sub-folder in local Inbox by right-click  > new folder. Created the folder 1 but it is not visible. If I go to create a new folder now, this folder shows up in the tree in the new folder dialogue, with my dragged folder as its sub-folder, but it is not visible in the left pane folders list. Can’t delete it or view it. And how did test 1 become its sub-folder? I moved test 1 before creating 1.

Tried to create another folder called from inbox , and it also did not show, but in the new folder dialogue, it shows and also as a sub-folder of 1.

Any ideas why this would happen?

BTW the solution to see the folders is to go to menu > tools > settings > general
Untick show local folders
Tick show local folders

Further, no sub-folders can be created for Inbox or dragged to Inbox from lower sub-levels. Any further attempts become sub-folders of 1. Inbox does receive new emails (by POP) without problem, and emails can be dragged between any folders without problem.

eM Client ver 7.1.30718.0