Links don't work

clicking on links in email using EM Client does nothing. Links will not open in browser. Browser does not load automatically when clicking on the link in the email.

Check that you have a default browser selected. In Windows 10, go to Windows settings and choose Apps > Default Apps. Then change the browser to Internet Explorer, then back to your preferred browser.

Does not work on my PC

Works but not with Chrome (IE = ok Edge = OK, Forefox = OK)… And I use Chrome…

I also use Chrome, and it works OK.

I would think it you set Firefox as default, and then it works, but when you set Chrome as default, it doesn’t, that it has something to do with your installation/configuration of Chrome.

But then again, it could be eM Client. What version of eM Client are you using Lubechi?

If you are using 7.2.36465 or 7.2.36694, you could download the latest version of eM Client from https://www.emclient.com/download. That is currently 7.2.36775.

Ok well, guys, after playing with the “default applications” setting for quite some time, it miraculously started working with Chrome ! Thank you the mystery of Windows.