Jump to links in html messages

Clicking on a jump-to link in an HTML message does nothing. It ought to jump down to the relevant section in the email.

Can you please rectify in a future release?


ctrl + mouse click does not work for you?

with regards

That works for HTML links to external URLs but not for jump-to links to tags within the email.

this should be implemented in 5th version already, try this version http://www.emclient.com/dist/v5.0.190… if this will not help then it is in 6th version already.


Thanks. The Beta version 6 has the fix.

you’re welcome :slight_smile:

If I read this query correctly it sounds like a problem I’m having.

When reading an article or some form of help and there’s a link to an email address for further assistance, clicking it (expecting to be taking to my email program with the addressee already completed) gives a similar warning to the one given above.

I tried to download the version you gave in a previous answer but apparently my version is a later one and I couldn’t install it.

After using Outlook Express with ease for so long I find this set up completely confusing.


Dave Crew

Hi Dave,

Did you setup eM Client as the ‘default’ e-mail client?

Tools > Settings > General > General

click [make default] button if possible.

screen shot:

Hiya Hans

Thanks for such a speedy reply and yes, I did make it the default mail handler (I should’ve mentioned that in my original letter).

I shouldn’t make heavy weather of it; It isn’t difficult to overcome and I’m quite thick so any reasons for it and workarounds would probably be completely lost on me. (I’m still trying to work out why my sister’s got two brothers and I’ve only got one!)

Thanks for your interest though.


Dave Crew

Hi Dave, can you please make a screenshot or a transcription of the error that you’re seeing after you click on such link?
Not completely sure if nothing else happens (except the error message) or if other applicaition is open instead.

Also what version of eM Client are you currently using (you can check this in Help > About)?

Thank you,

Hiya Paul

Whilst I appreciate your concern and help I don’t think it warrants too much time being spent on this problem. I mentioned it only because I thought I’ve incorrectly set it up and a quick amendment would rectify the situation. I certainly didn’t want too many people spending too much time on it.

It’s easy enough to copy the link and to paste it in the appropriate position in the email.

As you requested I’ve taken a screen shot and (hopefully) will include it with this letter.

Hi again, since it’s my job to help you guys here on the forum, I’m happy to assist you with resolving the issue, so first of all I can suggest to try and repair the installation.
Find out what version of eM client you’re using and either go to Control Panel > Uninstall a program, find eM Client on the list of installed applications and try to use the “Repair” button (without actually uninstalling it).

Or try to install this latest internal version of eM client http://www.emclient.com/dist/v6.0.20773/setup.msi .

Some people having a similar issue were having issues with mailto links and sending out emails through external applications because they didn’t have .NET framework version 2 installed or active on their computer, you can check if you have .NET 2 installed in the list of installed applications under control panel as well.

Let me know if any of these options helped to resolve the issue, or if you need further assistance with this, I’ll be happy to help.


Hiya Paul

There was one aspect I forgot to tell you in my last letter and that was the version I’m using. It was 6.0.20648.0. I was so concentrating on trying to send the screen shot that I forgot.

I went to the control panel as you suggested but it couldn’t repair it as according to them my version was newer than something or other.

I downloaded the newer version from the link you suggested (6.0.20773) but it didn’t seem to make any difference.

I’ve been a little suspicious of the new video driver I recently downloaded so rolled it back to the previous version; again it didn’t make any difference except that as in all my attempts to use the mailto function the screen suddenly became uncontrollable; in quick succession there appeared dozens of IE pages - loads of them. I’ve taken another screen shot but I’m not sure if it can render any help but it may give you some idea of the problem.

In many ways it’s helped me a lot as I’m now convinced the problem lays with my computer and not with your program. Naturally I scanned it for viruses and conflicts before I contacted you but nothing untoward appeared, thus my letter to you but I’m now as sure as I can be the fault is mine (my computer’s).

I’ll continue to investigate the problem if only to satisfy myself and if/when I find a solution I’ll let you know so you can relay it to anyone else with a similar problem.

Thank you so much for your concern and support. Installing the newer version may not have remedied the problem but I’m sure it’s erased one of the possibilities so I can now concentrate on my computer’s behaviour and performance.

As I said before the problem is hardly severe but now I know there’s something wrong with the comp it’s doubled my efforts to find it.

Thanks so much once again.


Dave Crew

Hiya Paul

As promised I’ve been looking for a solution and I think I’ve found it, well (crossed fingers) it seems to work for me.

The site I got it from is:


And the relevant passage I’ve quoted here.

1. Open Registry Editor (type regedit in start menu).

2. Locate HKEY_LOCAL_MACHINE\Software\Classes branch.

3. Check if mailto key is present and has a string value of URL Protocol attached. Note: keys are alphabetically sorted, so first there are the ones prefixed with a dot (file extensions), look for mailto farther down.

4. If HKEY_LOCAL_MACHINE\Software\Classes\mailto key is not missing in your registry, then the cause of your problem is somewhere else, try uninstalling IE10 (Programs and Fetures -> View installed updates -> locate IE10 and uninstall).

5. If HKEY_LOCAL_MACHINE\Software\Classes\mailto is missing as it was in my case, you have to restore it. In parent branch (Classes) right click, select New -> Key, name it mailto. In this new key create a string value (right click, New -> String value), give it name URL Protocol and you’re done. Close regedit and see if it worked.

Hope it’s of some help to someone.

Again, thanks for all your help.


Dave Crew

Hi again, I’m glad you’ve been able to find a solution for this issue, let us know if you come across this or any other issues or questions, we’ll be happy to help.

Thank you,