Is there still not a way to set a default calendar?

My colleague and I keep accidentally adding some events to the local calendar in the eM Client, rather than our Google Apps work calendars. We’re correctly synced with Google Calendar.

According to a previous post in the community forum, this was supposed to have been fixed with eM Client 6, which we have both downloaded. So … where can I change this setting?

Hi,
unfortunately there’s no settings to select the default calendar, if you’re creating a new event it should be created in the calendar you currently have selected.
If you selected more calendars you have to select the proper calendar while making a new event.

I hope this is not a big issue, but if you’d like to see some improvements in this area make an “Idea” topic for the feature and let other users vote on it,
if the user feedback is sufficient we might add the feature in future releases.

Thank you for pointing this out,
Paul.

the idea of an invite is to accept and have the calendar update automatically. are you saying I have to manually update my calendar for all invites?

Hi, if you receive a calendar invite it should be automatically added to the calendar for which you’ve received the invite, so if you have multiple calendars and receive an invite to, for example wayne@sterling.com and you accept it, it should be added to the calendar assigned to that account.

Thank you,
Paul.

Sorry I’m necroing this thread but I am a new user since last week and I am facing the same issue on eM7.

I usually receive .ics files by email. But then when I open the attachement it just selects a random calendar it seem.

So I guess this happens, because the email address I use to receive the .ics is not the same I use for my calendar. I use Fruux for my calendar.

Anyway each time I gotta click on the selected calendar and change it.

That’d be great if we could… assign a default calendar for email accounts that do not have their own calendar configured. Or something :smiley:

Same issue here

In account settings > general, there is an option to choose a default calendar. Is that what you are looking for?

@gary, where? I cannot find a way to default a calendar!

Go to Menu > Tools > Accounts and select the email account you want to assign a calendar to. Click on the General tab and scroll down to Default Folders.

Now event invitations sent to that email address will be placed in the calendar you selected.