Invisible Windows

I’m running 8 on Windows 10 and everything was working until earlier today where I can’t write a new email, reply, forward or anything that requires me to interact with anything but the main emClient window. When I hit the new or reply button a new window appears to be generated (in the task bar I can see a 2nd eM Client window) but the window is invisible. I can click it, it doesn’t pop-up. I can see it when I mouse over but it is just a blank window (see below). I have restarted the client and the machine, and even changed themes thinking that may have something to do with it. All with no luck.

Anyone have any ideas? Thank you.

Sounds like something within eM Client program itself has got out of whack with the GUI.

I would suggest to go to Menu / Backup and do a backup of your current eM Client.

Then uninstall eM Client and when asked do you want to delete the database, choose (No) and finish. Then download the latest version of eM Client from the version history page and reinstall eM Client.

Release History | eM Client
https://www.emclient.com/release-history?

1 Like

Well, that didn’t work. Uninstalled (left DB), rebooted, reinstalled and exact same thing is happening.

I really want to get off Mailbird, but just can’t get it working right!

Q What happens if you change screen resolutions ? Does that make any difference to the problem.

2 Likes

Indeed it does. The problem seems to be unique to the monitor’s native resolution of 3840x2160.

Ok. I’ve tested EMC today on 3840x2160 res using a AMD RX580 8GB video card & Adrenaline 2020 drivers with latest Windows 10 (20H2) and EMC V8.1.979 everything works as normal. Check you have the latest video drivers for your specific video card incase that might be the problem. Even try uninstalling and reinstalling your video card driver as sometimes that can fix glitchy things like that.

I don’t know if this is an issue with eg: Nvidia Drivers as haven’t had an Nvidia Card for sometime & never tested that B4. I’m sure other users on the forum will advise if its a known issue with Nvidia.

Failing that, if you have an IMAP or Exchange account etc (Non POP), make another backup of EMC, and uninstall EMC, and this time “delete your database” on uninstall. Then make sure the eM Client folder is gone in C:\ProgramFiles (x86) & C:\Users\yourname\AppData\Roaming if you have Windows.

Then reboot and run a free Registry checker like eg: Wise or CCleaner incase you have multiple entries of EMC in the registry causing it.

Then reinstall the latest version of EMC from the release history page above and setup as new to test if the new message window etc is normal.

If eM Client Program GUI new messages window etc (then works normal), Restore your database via Menu / File / Restore.

If you still have the same issue, try a eg: “System Restore” back to the point before this problem happened. Or if you have a “Backup Image” when it worked ok (backup your files) and restore the Image.

1 Like

Thanks… Here’s what I did… I changed the screen resolution and then went back to the original resolution and it is now working properly. :man_shrugging:

2 Likes

Just wanted to chime in here as I am having the same issue but worse.

EMclient was open while I was recording some screen videos in Camtasia at 2048x1152 and I think a Cintiq Pro 16 might have been involved there too. My graphics is Quadro M2200 on this 4k laptop.

When I changed back to 4k UHD, it crashed and now will not open without crashing in 20 or so seconds, no matter what I do and on either resolution. I have updated Windows, updated the graphics driver (Nvidia Quadro M2200) and tried removing and reinstalling EM including an earlier and latest versions and then upgrading and removed the database each time (I only use the calendar as I have to use Mailbird as you don’t support the 2FA in all the Outlunk accounts I am forced to use for the unis I teach at).

Any thoughts on anything else I can try?