intermittent delete error-can't delete

For months, I’ve had an intermittent problem deleting email. If I wait 5 min or so, it will clear and I can delete but it only reappears a few minutes or an hour or two later. It varies randomly. This is an every day thing 7 days/wk.

See error text below (is there no way to attach a jpg?).

My config: Using the current rev of eMC, IMAP account with ATT/Yahoo email. No other email, just one account. Synced with iCloud, etc.

I had zero errors or problems with POP. It all started with moving to IMAP so I could sync with iStuff.

Thanks for any guidance.

Here’s the error msg:

:an error occurred

[IMAP]Unable to upload message "Re: to folder “Trash”.
([SERVERBUG] UID COPY server error - Please try again later)

This begs the questions:

  • How long before all server bugs are fixed? This has been going on over a year.
  • What server? My ISP's server? eMC's server?

Hi, this error is referring to a server issue, e.g. your mail server (i.e. yahoo, gmail, ISP), eM Client does not use any other server than our licensing server, which checks if your license is valid, this doesn’t seem to be a license issue.

I’m not completely sure why exactly is your server not accepting the message you’re trying to upload, but it is possible it is the exact same message, try to remove this message from your trash folder by performing the repair function on the “Trash” folder mentioned in the error.

Right click the folder and select Properties > Repair and click on the “Repair” button.

Hope this helps,
Paul

OK, will try this. In a way, it’s good to know it’s the ISP server. I suspected eMC did not use a server for email xfer.

thanks for the response.

Ok, the repair fixes it temporairly  but I still get the error again later and have to repair trash several times/day. Then I can delete. Any idea where I should look next to figure out what’s going on?

Thanks.

Could there be a corruption problem with the account? maybe create a new acct. and delete old one? it’s an IMAP acct that’s synced with everything in iCloud.

Hi again, sorry for my belated reply, are you constantly seeing the same error? Maybe you’re seeing an error for another folder, maybe your junk folder?

Removing and re-setting up the account should help you get rid off the messages that can’t be uploaded to the server, so I can recommended using this option.

Thank you,
Paul

OK, just to clarify: multiple times every day 7 days/week, I get in a mode where it won’t delete. Says it can’t upload to Trash folder. If I wait 5-10 min, it will clear itself on its own. After your previous suggestion, if I run _ Repair  _  on Trash folder, it does fix it immediately 100% of the time, but it still comes back in 10 min or maybe 2 hrs., then a Repair again fixes it, etc…

I will create a new account and see what happens.

Thanks for the ongoing support!

BTW, I’m mistified by all the  whacky errors people are seeing. I get an email for every reported problem. I see none of that at all, but then I do have my own quirky errors like the one above and also a pop-up on restart or fresh boot saying IMAP log-in credentials are bad. I click cancel and everything continues ok. Seems a spurious bogus error msg. Saw the same thing on Outlook for years which is why I switched ti eMC. But I was getting many more errors with Outlook besides that one.

Hi again, can you please navigate to Tools > Settings > Advanced and enable IMAP logging for the problematic account?

  1. Save the settings
  2. Restart the application
  3. Replicate the issue
    Once the error reoccurs, please go back to the advanced settings window and submit the logs to us using the “Send logs” button, also please submit the data to my email mcgregor@emclient.com with a reference link to this forum topic.

Thank you,
Paul