Inserted images not staying in body of email but become attachments

Inserted images not staying in body of email but become attachments, annoying as I compose the body of the email with inserted images and all looks good.
When it arrives, the inserted images have become attachments and no longer in the email body.

What application is the receiver using to view the message?

Windows 10 chrome
And other friends systems

OK, so they are using webmail. Possibly they are viewing the message as plain text, or their webmail interface does not display inline images. They might ask their provider if there are options.

How does the message look in your own Sent folder?

Hi Gary,
In my sent folder the inserted images are now attachments.

That means that you sent the message as plain text.

Hi Gary, I responded to your email of the 20th with a screen dump of my compose settings in which I have HTML set as the default.
Even though the default is html, my emails end up in my sent folder as plain txt. ?
Can you assist me in why this is happening.

Can you send me a test message.

Create a new message, add an image as you normally would, and send it to me directly: gary@emclient.com

I have a variation of this problem. When I send a message with 2 attachments, one picture and one document, both titles are shown in the attachment area, but the picture also appears in the body of the text. How can i stop this happening?

When you are viewing a message with image attachments, they will also appear as a preview below the message body.

That is for display purposes only in eM Client, and may look different to the receiver depending on what email client they are using and how it displays image attachments.

There is no setting in eM Client to disable that preview.

This is because the message is being viewed as plain text.

Untick this setting:

image

I have the exact same issue.
Took a screenshot, tried to paste it within the mail body and became an attachment.
Saved as image file (Save as… in Paint) and then right click, insert image and chose the JPG I created and worked.
How to avoid such conversion to attachment?

Also, the mail is being shown as HTML.

Tried to create a new mail, and there is does work fine, only replying seems to be the issue.

Thanks

This is because your reply is using plain text.

Go to Menu > Settings > Mail > Compose > Mail format, and make sure that the reply format is also HTML.

Then try again.

1 Like

Thanks! This worked fine!

I have the opposite issue: in the emails I receive from one specific newsletter, the image at the top of each message isn’t showing and is attached instead. If I view it in webmail (Gmail) it shows correctly.

Are you maybe viewing the message as plain text?

Right-click in the message body and choose Format > Html?

If that resolves the issue, then change the setting permanently in Menu > Settings > Mail > Read and untick Read all messages in plain text.

The message is already in HTML format but that specific image appears as an attachment.

And is it an attachment, or do you think we are displaying it incorrectly when it is actually an embedded image?

If you want me to have a look at the original message, click on it and choose Forward > Forward as Attachment. This will create a new blank message with the original as an eml attachment. Send it to me gary@emclient.com and I will see what’s up.

It is definitely an embedded image. I will forward you the message, if you want I can add a screenshot of how I see it in Gmail’s webmail.

If you have Windows, sometimes images pasted inline images in the body of email clients only end up as attachments due to “clipboard corruption” in Windows or “a problem with the picture / bitmap” itself.

So first in Windows, to clear the clipboard, open a dos prompt and type echo off | clip and enter.

If that still doesn’t show the picture pasted inline when sent, then (before pasting in your email client) , copy the image to a paint program like eg: Paint.net or even the built-in Paint 3D and then paste into the body of your email.

Failing that, resave the image as a different image type / extension and then try pasting again. eg: If its a .jpg, try re-saving it as .png instead and then paste in your email.