Incorrect autodetection of Exchange settings in eM Client 6

Hi all.

Recently i decided to find alternative to Outlook and installed eM Client 6.
It made autodetection of Exchange settings and i was happy that everything will work itself.
But after that nothing worked. Erorrs when trying to connect to Exchange.
I tried installing Outlook 2013 and its autodetection worked flawlessly.
I was ready to leave eM Client but reading forums i’ve found the solution. It’s here:
https://forum.emclient.com/emclient/topics/cannot_connect_to_exchange_server
Our Exchange is behind proxy. I.e. mail1.site.com is Exchange and mail2.site.com is proxy.
After autodetection eM Client tries to use mail1.site.com as the server, but it can’t, because one must use proxy address for access. Manual changing mail1 to mail2 fixes the problem.
So my ideas are: 1) try to fix this situation in code; 2) if not - mention the fix in FAQ or manual.

Hello Idris, regarding this issue, where did you setup your Exchange account, was it out of your company network or during the use of the computer internally?

This can be related to your Exchange Autodiscover setup or the location of your network, e.g. if you’re in local or remote network away from the server.

For more information about this issue, please download this utility, http://www.telerik.com/download/fiddler and install fiddler on your computer. Run the utility and navigate to Tools > Fiddler Options > HTTPs > Decrypt HTTPs, and save the settings. Once you have fiddler setup, make sure it’s capturing traffic.

After you do so, please try to replicate the account setup in eM Client. Go to Tools > Accounts > New account, and setup your account using the automatic setup, and if the issue persists, please go back to fiddler and save the captured traffic logging to a fiddler archive. Submit the archive to my work mail, mcgregor@emclient.com with a reference link to this forum topic and we’ll check what might be causing this problem.

Thank you.

Thank you for the asnswer. I’ll do the job being at work tomorrow.