Inbox only showing email for about last 30 days

My incoming mail is only being kept for about the last 30 days. Did something change or did I just now notice this? How do I get it to keep all mail locally until I delete it?

Depends on the cause.

Did you set the account to only sync the past month? You will find this setting in Menu > Accounts then in the IMAP tab for the account.

Otherwise it could be that your email provider is deleting the messages after 30 days, or some other device or app connecting to the same account is doing that.

Another possibility is if you set automatic archiving, which you will find in Menu > Settings > Mail > Automatic Archiving. That will move older messages from the server to an Archive folder visible below your other folders.